Unable to install on Windows 10 - Due to .NET

  • 1
  • Question
  • Updated 3 years ago
Hi,
Trying to install MouseWithOutBorders on new laptop that is running Windows 10, but fails due with an error saying there is no .NET framework 2.0 or 4.0.

However I have 3.5 and 4.6 installed. 

Any ideas or planned updates for this ?

Thanks
Photo of whgibbo

whgibbo

  • 3 Posts
  • 1 Reply Like

Posted 3 years ago

  • 1
Photo of whgibbo

whgibbo

  • 3 Posts
  • 1 Reply Like
Just ran the .NET verification tool (https://blogs.msdn.microsoft.com/astebner/2008/10/13/net-framework-setup-verification-tool-users-gui...
And it verifies that the following are installed:
  • .NET Framework 2.0 SP2
  • .NET Framework 3.0 SP2
  • .NET Framework 3.5 SP1
  • .NET Framework 4 Client
  • .NET Framework 4 Full
  • .NET Framework 4.5
  • .NET Framework 4.5.1
  • .NET Framework 4.5.2
  • .NET Framework 4.6
  • .NET Framework 4.6.1
  • .NET Framework 4.6.2
Photo of Mouse without Borders

Mouse without Borders, Official Rep

  • 1112 Posts
  • 99 Reply Likes

The installer looks for 1 in the value Install under the registry key HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full. No idea why your machine does not have that.

You can work around by installing the app manually - https://getsatisfaction.com/mouse_without_borders/topics/unable_to_install_on_windows_7

Photo of whgibbo

whgibbo

  • 3 Posts
  • 1 Reply Like
Thanks.. 

Managed to work around it using the following command:
msiexec /i <install.msi> /qn
For future reference..