Closing Firefox logs me out of everything.

  • Question
  • Updated 5 years ago
Every time I close out firefox it logs me out of everything. This problem only started recently. My cookie preferences are correct. Any help?
Photo of

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 10
Photo of Finanzas

Finanzas

  • 124 Posts
  • 37 Reply Likes
Click the [+] to reveal the 5 causes, I suspect a corrupt cookies.sqlite file
Photo of

  • 2 Posts
  • 0 Reply Likes
That did it. I closed out Firefox, renamed it cookiesBACKUP.sqlite, and everything is back to normal.

Thanks for the help and for the quick reply!
Photo of Curious

Curious

  • 2 Posts
  • 0 Reply Likes
This fixed it for me as well.
Thanks
Photo of yodaddi

yodaddi

  • 1 Post
  • 0 Reply Likes
where can i rename it to "cookiesBACKUP"?
Photo of Finanzas

Finanzas

  • 124 Posts
  • 37 Reply Likes
1. Locate your profile folder - it's a randomly named subfolder of the
directory that opens when you hold down the "windows logo" key on your keyboard
and press R then in that Run dialog paste %appdata%\Mozilla\Firefox\Profiles
and hit enter.
2. Ensure Firefox is closed using File -> Exit from menu, and check your Task
Manager processes tab to be sure there is no firefox.exe listed.
3. In the subfolder you found in step 1 find the file named cookies.sqlite and rename it to cookiesBACKUP.sqlite
4. Restart Firefox, log into your sites.
5. Restart firefox again and revisit the sites to see if it logs you in
automatically (if you have chosen "remember me" or other option on the sites.)

The reason the cookies.sqlite database storage of your cookies gets corrupted is because of "cleaning" or "scanning" of tracking cookies done by security/privacy/ad killing software running on your system.
Find the settings for that function in that other software and disable it. The recommended Firefox add-on for better directly managing your cookies is CS lite.
Photo of Thomas

Thomas

  • 3 Posts
  • 0 Reply Likes
I never had the trouble before. I'm using Firefox 3.5.1 and I've checked the boxes "remember me" on the websites and Firefox preferences are set up to to keep my passwords.

But since I'm no geek and on a Mac I don't understand the above explanation. Someone does have an easy solution? thanks!
Photo of Finanzas

Finanzas

  • 124 Posts
  • 37 Reply Likes
For Mac OSX these replace steps 1 and 2 in the above reply

1a. Open the Terminal - you can do so from the utilities folder in your applications Screencast Tutorial
1b.. Into the Terminal type:
~/Library/Firefox/profiles/
1c. Using the screencast tutorial as a guide, open the randomly named subfolder of that directory.
2. From the menus in the Firefox window click on
Firefox -> Quit
Photo of Thomas

Thomas

  • 3 Posts
  • 0 Reply Likes
Thanks I'll try
Photo of Thomas

Thomas

  • 3 Posts
  • 0 Reply Likes
There is a easiest way on Mac:

Users --> Library ---> Application support---> Firefox---> profiles --->neiezxu3.default---> find the file named cookies.sqlite and rename it to cookiesBACKUP.sqlite.

Then everything is back to normal
Photo of Krista

Krista

  • 1 Post
  • 0 Reply Likes
It's probably a security thing. So someone else doesn't get on and sign on to your stuff. It's better for your safety in the end, although it's a hassle.
Photo of 2williampark

2williampark

  • 1 Post
  • 0 Reply Likes
go to tools options privacy and make sure automatically start private browsing is not ticked