Firefox won't open a new tab.

  • Problem
  • Updated 3 years ago
  • Acknowledged
Why doesn't apple+t work in Firefox to open a new tab?? How'd I manage to break that?
Photo of Josh (myles7897)J(

Josh (myles7897)

  • 339 Posts
  • 44 Likes

Posted 7 years ago

  • 74
Photo of Josh (myles7897)J(

Josh (myles7897)

  • 339 Posts
  • 44 Likes
Hi my name is myles7897, I volunteer giving support at Live Chat, http://support.mozilla.com/chat.

The cmd + T should open a new tab. The problem might be add-on related, try safe mode. Safe Mode is a special way of running Firefox that temporarily disables extensions, themes and toolbar changes. If your problem stops while in this mode, we can find the item that is causing the trouble.
Full safe mode instructions are at http://support.mozilla.com/kb/Safe+Mode.

--
Firefox support can be found in the form of a knowledge base, you can ask a question at support.mozilla.com, visit our chat room at irc.mozilla.org #firefox, or just post here at Get Satisfaction.
Photo of welch1W

welch1

  • 2 Posts
  • 0 Likes
Well, in safe mode, I can open tabs properly, but I don't know how to fix this outside of safe mode. Everything seemed to be operating in safe mode- addons and things. I'm SO confused!!!
Photo of welch1W

welch1

  • 2 Posts
  • 0 Likes
Never mind. I saw someone else's comment about Ask.com toolbar... that was the problem. I never use it, so I forgot I had it. When I installed something else, Ask came with it. Thank you for your help!!!
Photo of fuds.amirF

fuds.amir

  • 1 Post
  • 0 Likes
unistalling the Ask.com toolbar works
Photo of Pats4949P

Pats4949

  • 1 Post
  • 0 Likes
Hello i had same problem my Mozilla Firefox stop working for the last week i updated Firefox 10 had search web with Internet explorer found this one for you have to upgrade to Firefox Aurora 12 thot Ive installed the browser and lost everything, it loaded all same stuff is favorites from Mozilla Firefox i save, that i had load 2 pages what i save and it back to normal works great. Just go here this fixes ever thing for you.

http://www.softpedia.com/progDownl [...] -5787.html
Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
I use Firefox 3 on my mac and I have never had Apple + T not open a new tab. However, if you just printed something, that is bug 425844.
Photo of

  • 1 Post
  • 0 Likes
I experience this problem practically every single day, regardless on Vista or OSX.

If I have a flash video playing in one tab, I cannot open a new tab with the keyboard command.

Example: go to gizmodo.com or any other tech site
View an entry with youtube (or other video)
Click play.
Then while the video is playing; try to open a new tab using the keyboard command to do some product research while listening to the unboxing/review in the other tab.

Highly annoying behavior.
Works fine in Safari and I believe it worked fine in previous version of Firefox.

icerabbit
Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
If I have a flash video playing in one tab, I cannot open a new tab with the keyboard command.

...

I believe it worked fine in previous version of Firefox.


This has been bug 78414 since before Firefox. It's wanted for Mozilla 1.9.1, but not blocking. I'd say, maybe for Firefox 3.1, but more likely for 4.0, no guarantees. If you click the actual browser area (outside of flash), your keyboard commands will work again. There's also a bug for doing that with the keyboard, bug 93149.

(And we have no idea if @markbottrell was having an issue with Flash or not, he never responded.)
Photo of Stephanie Daugherty

Stephanie Daugherty, Support and QA Volunteer (un)official rep

  • 63 Posts
  • 13 Likes
This happens because flash is essentially a separate application running inside the browser window. While a flash application has "focus", it has control of the keyboard inputs, and the user must click on an area of the browser window outside of the flash application to give Firefox control of the keyboard back.
Photo of

  • 1 Post
  • 0 Likes
Thank you for the prompt response,

I was wondering if this was a known issue across the board or something with my setup, stumbled on this thread and felt I had to chime in when I read " I have never had Apple + T not open a new tab " ;)

Could have been something flash related for the original poster as well.

Thank you for the background information and bug #s.
Photo of

  • 1 Post
  • 0 Likes
I had the same problem too. With Mozilla Firefox 3.0.1 but when I disabled Forecastfox 0.9.7.7 the problem gone.
Photo of FleetieF

Fleetie

  • 3 Posts
  • 2 Likes
Installed Firefox 3.5 and (whooppee) everything worked even add ons apart from I could not open a new tab. By a process of elimination found that if I disabled AVG Security Toolbar from the add-ons everything was sweetness and light. May not apply to you but it worked for me.
Photo of Jennifer ErtmerJE

Jennifer Ertmer

  • 4 Posts
  • 0 Likes
I don't have a mac -just a regular little ol' pc -but this problem with tabs not opening just started for me about two days ago. I don't recall now what I was doing or had done but it does absolutely nothing now when I try to open a new tab.
Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
Maybe you have the AVG Security Toolbar like Fleetie did...
Photo of Jennifer ErtmerJE

Jennifer Ertmer

  • 4 Posts
  • 0 Likes
I did have the AVG Security Toolbar for about two days and, come to think of it, that is about when this issue began. However, because I honestly don't recall how the AVG Toolbar suddenly appeared on my computer and also, because I didn't like it at all since it also changed my home page and had the YAHOO search etc, I disabled it. Do I have to completely uninstall the toolbar and maybe if if upgrade to the 3. (whatever number) Firefox, this might cure the problem? Maybe worth a shot, huh?
Photo of Jennifer ErtmerJE

Jennifer Ertmer

  • 4 Posts
  • 0 Likes
Back to the drawing board, guys. I disabled, as I said above, the AVG toolbar about 2 days ago because I didn't like it, didn't need it, etc. and today now, I did the upgrade to 3.5 Firefox. I do have the new appearance across the top of the screen that indicates you can open a new tab but the "Open tab" function itself still ain't working.. Got any more suggestions. (Please keep any suggestions in very, very simple, easy-to-understand English though as I confuse quite easily when trying to comprehend "Computerese."
Thanks -Jeni
Photo of FleetieF

Fleetie

  • 3 Posts
  • 2 Likes
Go to 'Tools/Add-ons and make sure AVG Security Toolbar is disabled there.
Photo of Jennifer ErtmerJE

Jennifer Ertmer

  • 4 Posts
  • 0 Likes
Did the disable from the Tools/Add-ons too -and still nothing.
Photo of JudyJ

Judy

  • 1 Post
  • 0 Likes
the open a new tab not problem started a couple days ago. I had installed AVG free but the toolbar was already disabled so that isn't the cause. Tabbing worked great for months, very frustrating to not have it now.
Photo of Pete MerchantPM

Pete Merchant

  • 1 Post
  • 0 Likes
same here, i noticed it yesterday.. when i right click and select open in new tab, nothing.. all the other ones work, open in foreground tab, and open new window.... i use this all the time.. what happened??
Photo of Susan PopeSP

Susan Pope

  • 3 Posts
  • 0 Likes
I installed AVG 8.0 and didn't want the yahoo tab. I followed AVG's instructions: AVG dropdown menu > options > advanced options > uncheck "show yahoo searchbox on new tabs in browser" and this makes my file > new tab option not work. If I go back and check that box it works fine. Apparently I can have the yahoo tab or no tabs at all.

Disabling the toolbar in add-ons does nothing.

I went to AVG and reinstalled the free software (this time 8.5). Someone said it would give me the option to correct the previous installation, but it didn't. I suppose I have two AVG's now. Should have uninstalled first.

Anyway, that didn't help either.
Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
I would suggest opening a new thread in the Yahoo! board, since you say it only breaks when you turn off "Show yahoo searchbox on new tabs".
Photo of MagieM

Magie

  • 1 Post
  • 0 Likes
This just started 2 days ago, not being able to open a new page. I haven't installed anything. It just started. And there's a bar under my Yahoo toolbar that fills up with any pages I go to. Help.
Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
Can you post a screenshot? Here's a guide, and you can use the "Add an image" function of this site to upload the screenshot. Please save it as a PNG file, not the "Bitmap (*.bmp)" but "Portable Network Graphics (*.png)"
Photo of Susan PopeSP

Susan Pope

  • 3 Posts
  • 0 Likes
I should have been more clear. I didn't "install" anything either to start with. I just allowed AVG to update itself to 8.0. (And I didn't de-select the fine print note about making yahoo the default search engine (or whatever it said).
Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
You chose, through inaction, to install the Yahoo! toolbar. AVG installs the Yahoo! toolbar. You didn't tell it not to. You need to uninstall the Yahoo! toolbar.
Photo of Susan PopeSP

Susan Pope

  • 3 Posts
  • 0 Likes
Thomas,
Well, I had already done that to no avail, but yesterday firefox updated and now my AVG toolbar is gone and tabs open just fine -- blank. Problem solved.
Thanksl
Susan
Photo of jr2J

jr2

  • 1 Post
  • 0 Likes
I had this problem... disabled the AVG Security Toolbar and it is fixed... this needs to go in the AVG list, too, I'll put it there as well.
Photo of runnerfrog13R

runnerfrog13

  • 3 Posts
  • 0 Likes
I have this problem, but I do not have AVG anything. I can ctrl+click to open in a new tab, but many links I follow will open up new firefox windows instead of being redirected to a tab, despite having the option checked to "Open a new window in a new tab instead." Bookmarks will also open in the current tab, though I distinctly remember in one of the previous versions of Firefox I used (maybe 2.x?) that bookmarks would open in a new unfocused tab.

The addons I do have are:
Adblock Plus 1.1.3
IDM FlashPlugin 4.1
IE View 1.4.5.1
oldbar 1.2
Photo of Maurice H RichMH

Maurice H Rich

  • 3 Posts
  • 0 Likes
Likewise, no AVG anything at all, prob has surfaced in last few days, uncertain when ?

Adblock Plus 1.1.3
BugMeNot 2.2
Chrome View 0.2.0
Colorful Tabs 4.2
Download StatusBar 0.9.6.7
FireFTP 1.0.7
gui:config 1.0
IE Tab 1.5.20090525
IE View Lite 1.3.5
NoScript 1.9.9.47
PDF Download 3.0.0.1
Sage 1.4.5
StumbleUpon 3.63
WOT 20091028

Any further on this & any other suggestions for solutions.. Am slowly going through & checking my Extensions/Add-ons
Photo of psrich66P

psrich66

  • 1 Post
  • 0 Likes
Runner & Maurice share the same problem as I do. I don't have AVG anything either and suddenly the 'open in new tab' function stopped working. Since I don't see much help from Firefox/Mozilla coming, it's time to uninstall. If I want problems I'll stick w/ones that get a response from the manufacturer, i.e. Windows/Microsoft. They aren't perfect, but at least they respond. Adios, Firefox (and this is on 15 pc's that I have in my stores also) ALL have the same issue & I seriously doubt my staff downloaded the same problem causing program (or whatever) @ the same time. It sure looks like F/M is at fault and can't be bothered to repair it. While Microsoft isn't as cool, if it doesn't work it isn't cool at all! Adios, F/M. There's a reason why IE is still the most used...hassles and all.

PS: I don't have the yahoo toolbar on any of these PC's either, so that's not it. Bummer, but it looks like firefox has had plenty of time to address this issue and hasn't.
Photo of joshuaprichardsJ

joshuaprichards

  • 2 Posts
  • 0 Likes
You are aware that both Microsoft and Sun Java install plugins in Firefox without user consent, right? M$ .Net Framework add-on and Sun Java QuickStarter. Maybe an update to one of those *coughI'dcheckM$firstcough* addons caused the problem.
Photo of runnerfrog13R

runnerfrog13

  • 3 Posts
  • 0 Likes
I wasn't aware of that, actually. How do I find out what those plugins are, and/or disable them to test if that is the problem? (I am not quite sure the difference between a plugin and an addon)

I did try to install Silverlight so I could watch the Olympics - would that fall under said category? Maurice, prich66, did either of you install Silverlight at some point?
Photo of joshuaprichardsJ

joshuaprichards

  • 2 Posts
  • 0 Likes
Check Tools > Extensions
M$:
"Microsoft .NET Framework Assistant"
http://ffextensionguru.wordpress.com/...

Java:
"Java Quick Starter"
also there is a "Java Console" now too
http://forums.mozillazine.org/viewtop...

I don't have problems with these add-ons installed, but if something got borked during install (say, the "update" didn't complete and froze but you didn't know cause it didn't tell you it was installing that) and you shut off your computer, well, I imagine that or other scenarios could cause problems...
Photo of runnerfrog13R

runnerfrog13

  • 3 Posts
  • 0 Likes
While this problem is annoying, it's not enough of a hassle to make me uninstall Firefox and go back to IE. I have more problems with IE on a day to day basis than I have with Firefox overall. Plus, I've never had a response from Microsoft that has been helpful.

I've been thinking about this, and it sounds like not everyone has the problem, my husband can get new tabs to open just fine. I think it may be related to an addon or a plugin.

Maurice and I both have a version of IE View and Adblock Plus 1.1.3 - does anyone else have these and their firefox works? (or doesn't)
Photo of Maurice H RichMH

Maurice H Rich

  • 3 Posts
  • 0 Likes
I've not started to check addons/add-ins/plugins yet other than uninstall old unused/unneeded ones.. I was thinking of removing all Plugins/add-ins & checking if that fixed the problem. & then gradually adding in plugins one at a time to see what broke FF tabs from links.

NB I have this issue/problem on my primary work machine & no other machines (3) nor my home machine(1 at present)

Note that I can Ctrl-T to launch a new tab. I can also right-click a link & launch a new window aok..

PS regards IE I have a long-held saying - Friends don't let friends use IE .. If you're that keen to scrap FF, try Google Chrome instead.
Photo of FleetieF

Fleetie

  • 3 Posts
  • 2 Likes
I have Firefox 3.5.8
Adblock plus 1.1.3
FastestFox 3.1.2
ForecastFox 0.9.10.2
IETab 1.9.20090525
Microsoft.net Framework Assistant 1.1
Remove New Tab Button 1.0
Scrapbook 1.3.6
I don't run AVG at the moment but have done until recently -
have COMODO internet security (free)

and it runs brilliantly - wouldn't go back to IE
Photo of Maurice H RichMH

Maurice H Rich

  • 3 Posts
  • 0 Likes
aok, in the last day or two mine has now 'resolved' itself...
Photo of d0ti5

d0ti5

  • 1 Post
  • 0 Likes
For me, it was the Facemoods that blocked it.
Photo of Jeremy Denslinger

Jeremy Denslinger

  • 1 Post
  • 0 Likes
The trick with clicking outside of the Flash area worked for me. This makes me think that perhaps Adobe is deliberately breaking something, perhaps attempting to bind ctrl-t when they have no need to. This would, of course be something with the plugin, not the flash content.

Perhaps there's an alternative Flash plugin (from an Open Source project) that this will not be an issue with.