Special Characters Not Displaying in FF3

  • Problem
  • Updated 2 years ago
Special character do not display correctly. Instead of characters like a dash, ñ, etc, I get a square with numbers and letters in it.

I've tried changing my character encoding, but that hasn't worked.

Photo of

  • 1 Post
  • 0 Likes
  • undecided

Posted 6 years ago

  • 10
Photo of Joe D.JD

Joe D.

  • 2 Posts
  • 0 Likes
Same Problem. Special characters do not display correctly.

Changing the character encoding definitely doesn't help. IE7 displays same

page correctly. No Idea.

Photo of Thomas

Thomas

  • 1320 Posts
  • 115 Likes
those aren't special characters, those are apostrophes, possibly the weird smart apostrophes. for stenz, it's an — (—).

There's a few posts on this on the official Firefox Support forum:


Apparently it may be your choice of fonts :-/, but check that one with the long discussion and see if anything works for you
Photo of Joe D.JD

Joe D.

  • 2 Posts
  • 0 Likes
Thomas, Thanks for the quick replay.

No matter what encoding I choose in Options->Content->Fonts->Advanced it defaults to UTF-8, every time I reload page or restart FF3. The only solution is to go to View->Character Encoding and then force it to ISO-8859-1 for each page I’m viewing.

With ISO-8859-1 apostrophes are displayed correctly. :-) But I still got problem with “&” and “% “.

However, if I choose NOT to allow pages to choose their own fonts, set my font to Arial and use ISO-8859-1 encoding problem simply disappears.

Thanks!
Photo of Michael Parenteau

Michael Parenteau

  • 5 Posts
  • 0 Likes
My default font type and size was causing this issue. I now see special characters
Photo of Jephta KazondoviJK

Jephta Kazondovi

  • 1 Post
  • 0 Likes
how did you fix your problem, Michael?