Ubiquity 0.5.4 / 0.5.5pre7 not compatible with Firefox 3.6

  • Problem
  • Updated 3 years ago
When will a 0.5.* version of Ubiquity be available that is compatible with Firefox 3.6?
Photo of emteecE

emteec

  • 2 Posts
  • 0 Likes
  • frustrated

Posted 5 years ago

  • 49
Photo of y-lee

y-lee

  • 1 Post
  • 0 Likes
Seems to work for me but i had to change my skin to Simpliquity. The default skin did not display correctly.
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
Just created personal repository and uploaded the latest source as xpi.
Will update it periodically.
Photo of emteecE

emteec

  • 2 Posts
  • 0 Likes
Thank you.
Photo of guillaume.jayG

guillaume.jay

  • 2 Posts
  • 0 Likes
This is not working for me. I got an ubiquity notification :"setup failed"
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
> guillaume.jay
What errors do you get in Error Console?
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
FYI:

  • "latest source" means it is pre-beta and most likely has issues, which won't be fixed unless users report them in detail.
  • "Error Console" lies under Tools menu.
Photo of Víctor Fernandez

Víctor Fernandez

  • 1 Post
  • 0 Likes
still working on firefox 10 with ubuntu 11.10. Thank you
Photo of TiagoTiago

TiagoTiago

  • 1 Post
  • 0 Likes
Working on Firefox 11.0! Thank you!!!
Photo of petenlenP

petenlen

  • 2 Posts
  • 0 Likes
i just get a setup has failed icon come up in the bottom right hand corner...
Photo of petenlenP

petenlen

  • 2 Posts
  • 0 Likes
It's ok I just tried probably the same xpi on another topic and it worked this time thanks
Photo of guillaume.jayG

guillaume.jay

  • 2 Posts
  • 0 Likes
It's now working, i assume you updated.
Photo of westernengivoW

westernengivo

  • 1 Post
  • 0 Likes
On Mac OS X 10.5.6 Leopard running Firefox 3.6 I opened the ubiquity 0.5.5pre7.xpi from the official ubiquity beta link on the official ubiquity site. Then: error ubiquity 0.5.5pre7 is not compatible with Firefox 3.6.
Photo of Jono DiCarlo

Jono DiCarlo, Employee

  • 67 Posts
  • 14 Likes
You can also try installing version 0.1.9.1, from Addons.mozilla.com, here: https://addons.mozilla.org/en-US/fire...

This is based on the last stable version from the 0.1 branch of the code. It's not going to have as many features as Satyr's version, which is based on the 0.5 branch of the code, but it may be more stable.

Satyr, thanks a lot for doing all this work, and for building an XPI to share with the community!!

I have just updated the official ubiquity-related sites (https://mozillalabs.com/ubiquity/, https://wiki.mozilla.org/Labs/Ubiquity ) to point at 3.6-compatible versions.
Photo of

  • 1 Post
  • 0 Likes
thanks satyr!
Photo of

  • 4 Posts
  • 0 Likes
i second the gratitude!
Photo of C. Augusto Valdés

C. Augusto Valdés

  • 1 Post
  • 0 Likes
Tried to install but I get a 503 error, seems the link is broken
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
bitbucket seems having SSL issues. Try this instead.
Photo of BryanB

Bryan

  • 2 Posts
  • 0 Likes
This build works great for me, however I does seem to have a change in behavior. In 0.1 branch of Ubiquity, when running a google seach pressing 'Enter' would open a new tab in foreground. Now the default behavior is to open tab in background. I was able to figure out that pressing 'Ctrl + Enter' would open tab in foreground. Is there a way to alter this behavior?
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
> I was able to figure out that pressing 'Ctrl + Enter' would open tab in foreground.
Not 'Shift + Enter'?

> Is there a way to alter this behavior?
Turn on [Tools -> Options -> Tabs -> "When I open a link in a new tab..."].
(browser.tabs.loadInBackground in about:config)
Photo of BryanB

Bryan

  • 2 Posts
  • 0 Likes
Sorry typo, you are correct, 'Shift +Enter' opens tab in foreground. I do agree with jojomaleiro though. I'd like only foreground tabs with Ubiquity. Thank You for you work on Ubiquity. I don't know what I'd do with out it!!!
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
> I do agree with jojomaleiro though. I'd like only foreground tabs with Ubiquity.
All right. Two more votes and I'll add an option for it. ;)
Photo of netwolfukN

netwolfuk

  • 1 Post
  • 0 Likes
+1 for me please. I'd like to be able to have tabs load in the foreground for ubiquity, but in the background for normal links. Thanks for keeping ubiquity alive. I really appreciate it.
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
That vote is kind of reset as the issue now has an individual topic.
Photo of jojomaleiro

jojomaleiro

  • 6 Posts
  • 0 Likes
Yes satyr, that works but that option for me is handy to have unchecked, ubiquity is the only thing i want to be able to open in foreground. If i'm not wrong at some point there was even that option in the ubiquity settings page.
Also the Alt+1/2/3/etc short isn't working and that was so so handy, i found that Ctrl+Alt+"number" does the trick but that short just isn't handy.

Beside all this BIG THANKS for keeping the best addon ever alive.
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
> that option for me is handy to have unchecked, ubiquity is the only thing i want to be able to open in foreground.
I was reluctant to add another pref just for this purpose (as the rest of Ubiquity team is quite anti-prefs). Note that the setting applies to every page Ubiquity opens, including links in preview.

> there was even that option in the ubiquity settings page
Not that I know of.

> Also the Alt+1/2/3/etc short isn't working and that was so so handy, i found that Ctrl+Alt+"number" does the trick but that short just isn't handy.
The binding for accesskeys in preview has changed to the content one. This is because the preview no longer has chrome privilege due to security concerns. You can tweak this by modifying ui.key.contentAccess (4 for Alt only).
Photo of jojomaleiro

jojomaleiro

  • 6 Posts
  • 0 Likes
Thanks for the fast reply, i know it applies to every page Ubiquity opens and i found it to be very handy, but i guess i'll have to change the option at the "tabs" sub menu. About the option to do it i might be wrong but i clearly remember a check box for it, thou i might be confused with some other soft or addon. And finally thanks for the tip about the ui.key.contentAccess.

Again thanks for keeping Ub alive. I can't even conceive why they dropped the project.
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
For now, you can use this snippet to tweak the behavior.
Photo of jojomaleiro

jojomaleiro

  • 6 Posts
  • 0 Likes
Sorry mate but i am lees than a noob at programing, so i have no idea where to put that...can you give me a hand
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
Just subscribe to it (see the notification above right?), or paste it into Command Editor (about:ubiquity?cmdlist).
Photo of jojomaleiro

jojomaleiro

  • 6 Posts
  • 0 Likes
Thanks mate, i probably missed the subscrition bar, it was late yesterday ;)

Big Thanks, and keep up the great work.
Photo of David Sandey

David Sandey

  • 4 Posts
  • 0 Likes
Satyr.. Thanks for the awesome update :D I have a minor problem that I am not sure how to resolve. I have a multi-monitor setup and the I have Firefox open, and it isn't open fullscreen, on a secondary monitor. When I open Ubiquity it always appears on the primary monitor. If it is open fullscreen on the secondary monitor everything works well.

This was working correctly with prior versions of Ubiquity.
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
Looks like Firefox doesn't like them.
With which versions of Ubiquity/Firefox exactly?
Photo of jackbovarixJ

jackbovarix

  • 1 Post
  • 0 Likes
satyr, thanks for the up, but... I'm facing the following problem : Installs ok, seems to work, while typing something Ubiquity shows responses, but when typing 'enter', it absolutely refuses to open any new tab, nor window ; in fact, it does nothing at all... I'm almost sure this is minor config trouble, but i dunno what to do...

version 1.9.1 worked, but, as I'm french I would be, thanks to you, much more comfortable with 0.5.5...
Photo of

  • 1 Post
  • 0 Likes
Official Ubiquity 0.5.4 works just fine with 3.6.3.

Just unzip the *.xpi file (it's a regular ZIP file)
edit the install.rdf and replace "3.6a2pre" with "3.6.*" then compress the folder contents with your edited install.rdf as zip and rename the .zip extension to .xpi.
Drag the new .xpi onto the Add-Ons manager and let it install.

Ubiquity 0.5.4 and 3.6.3 don't exzibit any of the theme not rendering correctly (white backgrounds etc.) problems as some of the other versions do.

I am grateful for Satyr's version, it's just that I couldn't use it because of the rendering problems with any of the default themes.
Photo of timT

tim

  • 5 Posts
  • 0 Likes
now that the tab behavior has returned to the old way, ie switching to the new tab when a ubiquity command is executed, can you offer a snippet to keep it as the "new" behavior, ie opening the tab in the background? Thanks,
Photo of satyr

satyr, Employee

  • 101 Posts
  • 39 Likes
Open about:config and set browser.tabs.loadDivertedInBackground to true.
Photo of timT

tim

  • 5 Posts
  • 0 Likes
that'll do! I did like the behavior of ubiq loading in background, but normal "new window" tabs being switched to, but this is fine.
Photo of X

X

  • 1 Post
  • 0 Likes
Anyone able to get ubiquity 5.5 running on the latest firefox 4 beta ?
(Firefox 4 Beta pre8)

It seems some scripts dont work properly like "tr" and the bugmenot script by vic shih here ~> http://blog.vicshih.com/2009/04/bugme...

Any thoughts would be helpful.
Photo of jan.magne.landsvikJ

jan.magne.landsvik

  • 1 Post
  • 0 Likes
This one works on FF4.Release
https://mozillalabs.com/ubiquity/2010...

//Jan Magne
Photo of Madsoul Lous

Madsoul Lous

  • 1 Post
  • 0 Likes
Sugoi Satyr! Thank You very much.
It ́s working fine in FF5 for me.
Photo of Thomas Veil

Thomas Veil

  • 1 Post
  • 1 Like
Hi Satyr - thank you so much for keeping this updated. I really love ubiquity and can't stand that it was discontinued.
If there is any donations needed to keep this alive I would be happy to do my small part. Maybe a proper website would also help to keep a bigger user-base for this and spark more interest. Because I had really trouble finding this new version.
Photo of escapeE

escape

  • 3 Posts
  • 0 Likes
Satyr thank you!!!
Photo of MontblancM

Montblanc

  • 1 Post
  • 0 Likes
Thank you so much, it works great on 7.0.1! :) I really missed Ubiquity, I can finally start browsing comfortably again!
Photo of Dr1nkyoghurtD

Dr1nkyoghurt

  • 1 Post
  • 0 Likes
I really miss this addon, doesn't seem to work on firefox 12.0 unfortunately and hasn't worked for over a year with me. Someone should resurrect this again. Best plugin for firefox ever!
Photo of Teoh Han HuiTH

Teoh Han Hui

  • 7 Posts
  • 0 Likes
Works for me on Firefox 12. Make sure you are using the latest version from Satyr.