Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m On the brink of giving up!

(Error code: ssl_error_rx_record_too_long) one thing after another!

I am getting a error that reads,

An error occurred during a connection to mail.amberlightaviary.com:143.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

I am really not even familier with computers so i already strugled my way throguh manulay adding my email to mozilla, and im really close to just giving up and going back to outlook express.

Why am i getting this errer? What do i have to do to fix it? Did i set up the new email account wrong or something?

I downloaded thunderbird once it didnt work then i saw some things about manulay setting up your new accounts so uninstalled thunderbird reinstalled it manuly set up a new email account and this is what im getting.

Please help ASAP or im done with thunderbird and i'll be moving onto something else!
6 people have
this question
+1
Reply
  • I’m pi$$ed
    I got it to go away by going to edit...account settings....server settings.....security settings... and took out ssl/tls and chose "none"
    I feel my provider changed some thing in their settings, and it only does this on the latest version of tbird, my netbook is just fine with an older version on it. furthor when it happened about 4:30 today I was doing nothing different and had not recieved any emails around that time. some one needs to get their krap together and quit using microsoft products to test to see if "it" works. I have used linux since xp hit the retail market. john
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated happy, confident, thankful, excited