Help get this topic noticed by sharing it on Twitter, Facebook, or email.

font size

How do you change the font size in emails while using
Thunderbird 3.0 ?
19 people have
this question
+1
Reply
    • Please Mozilla, sort out fonts in Thunderbird 3. Allow users choose compose and display fonts in actual point size rather than "small, medium, or large". Make the fonts display within the Thunderbird client as they would in a word processing programme such as Microsoft Word.

      Thunderbird's IMAP capabilities make it a really good email client. Why render it so frustrating by virtue of this problem with font size?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m frustrated
    Figgs,
    The guy is asking about 3.0 and you give him an article for 1.5 and prior. THe fonts in 3.0 are a real problem (bug?) and some us need a real answer.
    - Stephen
    • Stephen - you are right that the article i referred to is for an older version of T-Bird. However the steps needed to change the fonts are almost identical to those in the article (although I should have noted this difference)

      The bug that i believe you are referring to is covered in this thread:
      http://getsatisfaction.com/mozilla_me...

      The good news is that there does appear to be some progress being made on this according to the bugzilla ticket that is mentioned in that thread. We're all waiting for a resolution to this issue.

      figgs
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • This reply was removed on 2010-01-25.
    see the change log
  • I have windows 7 and have gone to my "control panel" and used the "font" option to set my default at 150%. I works well. I assume you can do this same thing in XP or Vista.
    • First I write something that is not an answer :-)

      I have windows 7, a new Lenovo R500 laptop, and I had to change the above mentioned option in Control panel (I would like to change screen resolution instead, but the result is very ugly.)

      If I use 150%, the message list receives additional space above and below each message, so about fifty percents of space there is used. [I think this ought to be fixed.] And anyway with "150 %" not much fits into the screen in Thunderbird 3.

      So I decided for custom 140% in Control panel (One has to change Categorized view of Control panel to "small icons" on Control Panel Home, urghhh)

      Now, its about OK.
      But, when I want to WRITE message, it is displaed with VERY small font size, its about 10pt regardless the font settings mentioned elsewhere here.

      Ok, there is "Size" in "Tools -> Options -> Composition -> General -> HTML Options" as document at http://kb.mozillazine.org/Font_settin....
      But, as documented in the same place, the size change is Sent to the recipient (I verified with combined plain+HTML format).
      Let me cite "It is usually a bad idea to change these settings, because people who receive your messages might find the messages difficult to read."
      and "Keep in mind that people do not all have their monitor resolutions set the same as yours". The developpers should keep this in mind and do not let the option influence the sent mails.
      .....
    • First I write something that is not an answer :-)

      I have windows 7, a new Lenovo R500 laptop, and I had to change the above mentioned option in Control panel (I would like to change screen resolution instead, but the result is very ugly.)

      If I use 150%, the message list receives additional space above and below each message, so about fifty percents of space there is used. [I think this ought to be fixed.] And anyway with "150 %" not much fits into the screen in Thunderbird 3.

      So I decided for custom 140% in Control panel (One has to change Categorized view of Control panel to "small icons" on Control Panel Home, urghhh)

      Now, its about OK.
      But, when I want to WRITE message, it is displaed with VERY small font size, its about 10pt regardless the font settings mentioned elsewhere here.

      Ok, there is "Size" in "Tools -> Options -> Composition -> General -> HTML Options" as document at http://kb.mozillazine.org/Font_settin....
      But, as documented in the same place, the size change is Sent to the recipient (I verified with combined plain+HTML format).
      Let me cite "It is usually a bad idea to change these settings, because people who receive your messages might find the messages difficult to read."
      and "Keep in mind that people do not all have their monitor resolutions set the same as yours". The developpers should keep this in mind and do not let the option influence the sent mails.
      .....
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • 2
    This worked for me! Here's the steps I used to change my fonts:
    Open E-mail. Go to Tools. Options. Display. Change fonts. Wa-lah!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • This might be an answer:

    [For windows 7]
    In C:\Users\\AppData\Roaming\Thunderbird\Profiles\
    create direcotory "chrome"
    in which create file "userContent.css"
    in which put the following

    body {
    font-size: 25px !important;
    background-color: #0000FF !important;
    }

    This affects all outcomming and incomming mails in the way you SEE them.
    In reality it does not change their content.

    Restart thunderbird, otherwise it does not notice any change.
    (Remove the color line after testing.)

    For other Windows, the path should be similar, perhaps without "Roaming".
    For other OS see http://kb.mozillazine.org/UserContent... and links therefrom.

    If you are dissatisfied, you can simply delete the .css file and restart TB.
    Align 25px to yor needs.

    I hope this might work for you.
    Be sure not to include any absolute size font commands (which is not a good idea anyway). This might perhaps happen with some addons or mail templates. Something similar also happens, e.g., when you change Font size from menu. Do not do that. (Actually, perhaps you can do that, what you see is wrong then, but the real result is perhaps correct -- see the HTML code, it seems to produce: ) Better use Ctrl + (-) for bigger (smaller) size.

    -------------
    And sorry - why angry - I was not happy to write only to see afterwars I have to create a login here.
    • Corrigenda: Might be this only works for incoming HTML and outgoing HTML mails. If this is the case, bellow is full content of my userContent.css file. Far from perfect (it reinforces font size also on inside elements of mail as can be seen by "debug" colors) but it might be of some use.
      (Somebody might find a better solution, even if for particular mails, by using DOM inspector and then codding according to http://www.w3.org/TR/css3-selectors. )

      /*
      * { font-size: 25px; }
      */
      /* font-size: 25px !important; */
      /* font-size: 16.8px !important; */
      /* font-family: Arial !important; */

      *.moz-text-flowed /* toto je plain text mail ale NEFUNGUJE, FUNGUJE
      mozna proto, ze tam ma style:
      style="font-family: -moz-fixed; font-size: 14px;"
      class="moz-text-flowed"
      (Mohl bych to zkusit aplikovat na prime potomky.
      */
      {
      font-size: 25px !important;
      background-color: #F8F8F8 !important;
      }

      *.moz-text-html /* toto je mail v html */
      {
      font-size: 25px !important;
      background-color: #FFf7f7 !important;
      }

      *.moz-text-plain /* plain text II */
      {
      font-size: 25px !important;
      background-color: #FFf6FF !important;
      }

      #msgcomposeWindow
      /* toto je vytvareny mail NEFUNGUJE
      presneji: tady to nefunguje, ale (asi)
      funguje to v userChrome.css
      (jenomze to asi do mailu sameho neproleze, prece) */
      {
      font-size: 25px !important;
      background-color: #0000FF !important;
      }

      #content-frame /* vytvareny mail --- funguje, ale nepronikne */
      {
      font-size: 25px !important;
      background-color: #00FF00 !important;
      }

      body /* FUNGUJE FUNGUJE FUNGUJE */
      {
      font-size: 25px !important;
      background-color: #f8f8FF !important;
      }
    • Make sure your new file has indeed .css suffix. You need something like unchecked "hide type of files with known type" in Folder settings of Windows Explorer)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • I’m frustrated
    Check this out:

    I've tried EVERYTHING, and I mean EVERYTHING to make all mails look like the top text. I've googled, and done EVERYTHING suggested. Still the font is gigantic on SOME mails, not all. It's very frustrating. :-(
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • That missing font-size dropdown menu when editing message is not good. Similar problem is when I want empty compacted folders with one click - I need to downloading external plugin. This is nonsense, that basic settings are missing.
    Currently I am using this tedious solution: copy the message to Notepad, so it will become unformatted and then back to thunderbird, so it will have unified font-size.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Yes, notepad is the "must-have!" add-on for Thunderbird :-)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated