Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Thunderbird not working with AVG antivirus.

I have just installed Thunderbird 17.0.2 on a Win 7 machine running AVG antivirus 2012 (free version, with "Personal email scanner" installed). IMAP mailbox. Thunderbird works fine with the AVG antivirus disabled. With AVG running, it will download only the message headers. When attempting to open any new message it continually says "Downloading message...".

Is there anything to try please other than changing to another antivirus program?
1 person has
this problem
+1
Reply
  • You are better off with Thunderbird's SSL/TLS and no virus scanning of your mail. The anti virus program, if it does it's job properly does not need to be scanning your mail as it will detect and stop any virus as soon as it tries to execute.

    AntiVirus programs have some kind of a 'resident shield' looking for virus like activity and stopping it. Thunderbird does a lot of it's own security work, scripts (which is how most malware is transmitted in emails) simply do not work in Thunderbird.

    Please read this, http://thunderbirdtweaks.blogspot.com...

    After all this, it you still want to disable it, go to Tools > Account Settings, and in Server Settings under the account, on the right change Connection Security to None.

    Then at 'Outgoing Server (SMTP)', highlight your account, click Edit and change Connection Security to None. You'll probably have to tell the AV program what the security should be.

    By the way, with some AV programs, if they scan your email and find something questionable and go to delete or quarantine it, that whole email folder (your inbox - which is really just one file) could disappear.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Thanks Stan.
    Connection security in Thunderbird was already set to "none" for both incoming and outgoing email (I'm not sure whether my ISP supports SSL/TLS).
    I have turned off just the email protection component of the AV, and this seems to have fixed the problem.
    Problem solved, I think!
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Hmm this is interesting. I use a different free antivirus (Unthreat Antivirus) and it works perfectly for me with Thunderbird so it may be an issue with AVG.. Have you thought of switching an antivirus?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated