Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Firefox 3.5 for MAC: Pluggin Bug

The pluggin doesn't work in Firefox version 3.5 for the MAC. The mentalspace team is aware of this and will let you know once this is fixed. Thanks!
1 person has
this problem
+1
Reply