Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Missing Nero Control Centre

After all the problems I had trying to get Nero 2017 & 2018 to work on my AMD computer without success and eventually (no thanks to Nero Support who don't seem to have a clue about their own products and incompatibilities) having found the root cause with help from here (Wither 1), I now find my original Nero 2014 Platinum won't correctly re-install after at Nero Support's insistence that having 2014 still installed that was the cause of the problem (which it wasn't) and that I wipe out everything Nero on my computer. Now it tells me to download Nero Control Centre (so I can add my serial numbers) from a link which just takes me to the Nero upgrade page.
How do I fix Nero Platinum 2014 and make it work again? I thought Nero Control Centre was automatically installed as part of the program.
2 people have
this problem
  • 1
    Hi David,
    Nero Control center *should* allow you to add a serial number for an earlier version ... If the earlier version is installed, it should then work?

    Unless you have re-installed it more than 5 times ... so the system might have "locked it" ... in which case sending an email to patent, with the serial number details, requesting a reset/activation would fix that issue.

    If you are missing Nero Control Center completely though ... maybe this old method would work for you to install that component ...
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • Hello Phil and Wither
    Sorry, all the problems with Nero just got on top of me and I have been trying to get my computer back up and running as something screwed up and I couldn't get it to run, it just kept telling me it had to restart to fix an error but never fixed anything. I finally got it up and running a few days ago but I have been flat out working and I had lost the original thread somehow.

    I ended up totally uninstalling everything to do with Nero. Unfortunately the changes in drivers made absolutely no difference, in fact they wouldn't even install.
    Phil - I tried what you suggested - Nero Control Centre can't be installed because it already exists... well so said Windows. I went looking for it... no it doesn't exist anywhere. The HKey stuff... well I followed that through to Software and there it stopped. The full string you gave me did not exist (I even put it in search and it came back negative). So I tried running Nero again but it still said Control Centre was missing and install it from the link that doesn't work anyway. Thus, suitably pissed off with Nero I decided to uninstall it. When I went into the UNinstall in Windows Nero didn't exist, yet Nero files were in my Program Files and Nero 2014 was installed. I have no idea what the hell happened but I finally managed to totally get rid of Nero from my system... or so I thought. I reinstalled my Nero 2014 and got the same thing - control centre is missing. I uninstalled it again and ran a registry cleaner through that I hope has cleaned all traces out this time. When I have time I will try reinstalling it again.
    If NERO SUPPORT had said when I first contacted them that there is a known incompatibility with AMD Radeon drivers all the problems and ill feeling to Nero could have been avoided but they kept insisting there were NO compatibility issues and telling me to do all manner of useless things such as uninstalling my 2014 Platinum which was never an issue. Now thanks to Nero Support, that is screwed up too.
    I appreciate the help you guys have offered in trying to resolve the issue but ATM I have to try and reinstall it and hope it works this time. Failing that I may have to reinstall Windows so as to absolutely guarantee there is no trace of Nero in my system. Not related to Nero but somehow my restore points all vanished bar one and that one was corrupted anyway.

    I ended up getting a refund for my purchase of 2017/18 since there was no way it would work on this computer and Nero Support accused me of using a licence bought on eBay or somewhere else when they sold me the damned program and they knew it. I gave them a copy of my purchase receipt and after that they wouldn't even reply to me so I said stuff you and got my money back. I have never had so much trouble with Nero and got so little useful support from Nero directly.

    I may not respond again for a while but I will let you know if I have any success at getting my Nero Platinum 2014 to work again.

    • Quite a nightmare. Good luck with getting your 2014 going again...

      Perhaps another go at using the Nero FirstAidKit to clear the registry followed by a fresh download of the 2014 installer would work ...

      Nero created a tool (Nero FirstAidKit) which might solve some installation problems.
      This tool will delete all registry entries of your Nero installation(s) and will allow a clean reinstall of Nero.
      Please note that the Nero FirstAidKit deletes Nero related registry entries only -> all Nero folders and files still
      remain on your system.(but Nero applications cannot be used anymore)
      These remaining Nero folder and files will be overwritten automatically once you have completed a new installation of Nero.


      Please proceed as follows:

      Download the Nero FirstAidKit from

      to your harddrive.

      (copy the above link and paste to your web browser)

      Unzip the ZIP-file with WinZip or WinRAR and save the content to your hard drive.
      Double-click on the unzipped EXE-file to start the Nero FirstAidKit.
      -> The window "Nero FirstAidKit (for test only)" will open.

      Confirm the message to remove the Nero entries with YES.
      -> A status window will open.
      The execution of the tool may take several minutes.

      Please wait until the progress has been completed.
      -> The message "Finished cleaning up" is displayed.

      Close the window by clicking the "finish" button.
      -> Nero FirstAidKit has removed all Nero entries from your registry.

      Now start the download and the installation of Nero 2014 again:
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • If I remember correctly, you have a 32 bit system.

    If so, go here-

    C:\Program Files\Nero

    There should be a Nero ControlCenter folder.

    Is it there?
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. sad, anxious, confused, frustrated indifferent, undecided, unconcerned kidding, amused, unsure, silly happy, confident, thankful, excited

  • 1
    No, mine is 64 bit. When I went into C:\Program Files\Nero, Control Centre didn't show up. A SEARCH of C drive did not reveal it either yet trying to install it again Windows said it already existed, but go back and OPEN NERO and it says to install Control Centre. So sum ting wong, (Windows tells lies), what I don't know but... After (I thought) I cleaned it off the system again....

    Anyway I decided I'd give it a go and reinstall 2014 (fpr about the 20th time). When I installed it my serial number was already in there in Control Centre, so even though I thought I had wiped out Nero totally some part was hiding from me.

    I loaded a file which came up as video (last time all I got was audio) and converted to mp4 no problem. So it looks like everything is now working fine and I won't be upgrading to a later version until I need to replace this computer and then I'll go back to Intel.

    I appreciate your help even though it didn't manage to resolve the issue but at least I know WHY 2017/18 won't work in this computer I cannot believe that Nero Support does not know this. Absolutely nothing they said to do resolved the problem with 2017/18 and in fact all it ended up doing was frustrating me all the more and causing more problems. You at least knew WHY it wouldn't work and offered what at least seemed like a solution even though ultimately that din't work either.

    Don't you just hate GREMLINS!!! GRRRRRRRRRRRRR!!!!!

    Once again,. thanks both of you for your help.
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. happy, confident, thankful, excited indifferent, undecided, unconcerned kidding, amused, unsure, silly sad, anxious, confused, frustrated