As of approximately Jan 10, list view of NewsBlur shows only ~20 items and no more. I have to reload to get 20 more items etc.

  • 2
  • Problem
  • Updated 3 years ago
Longtime user, but NewsBlur is loading only a limited number (about 20-40) items at a time; then it is necessary to reload. This appears to apply to top level only; it does not seem to occur with subsidiary sites. I have 51 sites currently, about 3000 items in all.
Photo of Christopher Hall

Christopher Hall

  • 3 Posts
  • 1 Reply Like

Posted 3 years ago

  • 2
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
That is weird. What client are you using, the web?

I may have seen this too, but it only happened when I was reading a story. Oh shoot, I just realized what's happening. About a week back, so when you wrote this bug up, I changed the dashboard river to perform a full reload every 60 minutes from every 10. That should fix much of the problem. 

Come to think of it, I should probably turn off dashboard river reloads while you're reading the folder it's in, thereby preserving the cached list. 
...
Fixed and deployed. Sorry for live debugging that one but it got it fixed, so there's that.
Photo of Nrbelex

Nrbelex

  • 52 Posts
  • 2 Reply Likes
I am continuing to see this issue on web as recently as tonight. If I click the Home button, then return to All Site Stories, I can go beyond a handful of stories. Otherwise, I can only read about 10-20 stories before hitting the supposed end of my stream. A refresh with a cache clear does not resolve the problem.
Photo of dkcd

dkcd

  • 1 Post
  • 0 Reply Likes
Same for me, for a few weeks now. At the moment: 27 unread stories, only 16 stories in the stream.
Photo of Christopher Hall

Christopher Hall

  • 3 Posts
  • 1 Reply Like
Thank you for looking into this. NewsBlur is a great product, and I appreciate all the hard work you've invested in it.
Photo of Christopher Hall

Christopher Hall

  • 3 Posts
  • 1 Reply Like
My thanks may have been premature. This is still occurring. Using Windows 10, problem present on both Firefox and Chrome.