Bug: Youtube video fetcher broken/buggy

  • 3
  • Problem
  • Updated 1 month ago
I further tried to narrow down what I've written in this topic and came to the conclusion that the youtube video fetcher really seems to have a bug.

Please see the following opml: all the RSS feeds are valid and perfectly shown in the browser. I can also import them without problems in other readers (feedly, inoreader). But for whatever reason Newsblur says that the feed are broken.

<---- snip ------>

<?xml version="1.0" encoding="UTF-8"?>
<opml version="1.0">
  <head>
    <title>Youtube feeds that are not correctly imported in Newsblur </title>
  </head>
  <body>
    <outline text="Youtube" title="Youtube">
      <outline text="Deutscher Alpenverein" title="Deutscher Alpenverein" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCLNVO6TQ8vUGiSgVc-7hWiQ"; htmlUrl="https://www.youtube.com/channel/UCLNVO6TQ8vUGiSgVc-7hWiQ"/>;
      <outline text="Jesús Amaya Guitarra" title="Jesús Amaya Guitarra" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCQUUysbbowBlnmL4XF5fQQw"; htmlUrl="https://www.youtube.com/channel/UCQUUysbbowBlnmL4XF5fQQw"/>;
      <outline text="Map&amp;Guide" title="Map&amp;Guide" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UC09fqoXU9moUocftVLLTctA"; htmlUrl="https://www.youtube.com/channel/UC09fqoXU9moUocftVLLTctA"/>;
      <outline text="Michael Nyman" title="Michael Nyman" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCCAuVN4JcLYNaG7b-XEPaYw"; htmlUrl="https://www.youtube.com/channel/UCCAuVN4JcLYNaG7b-XEPaYw"/>;
      <outline text="The PTV Group" title="The PTV Group" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCiioH25tZ_w447aGN9fRb0g"; htmlUrl="https://www.youtube.com/channel/UCiioH25tZ_w447aGN9fRb0g"/>;
    </outline>
  </body>
</opml>
Photo of Stefan Schelling

Stefan Schelling

  • 14 Posts
  • 1 Reply Like

Posted 2 months ago

  • 3
Photo of Bill B

Bill B

  • 22 Posts
  • 1 Reply Like
Can confirm I'm seeing this across my feeds as well. At least one of which has new content on the feed that Newsblur doesn't grab.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6512 Posts
  • 1474 Reply Likes
Thank you for bringing this up. I just pushed out a fix. All YouTube feeds should now be working (or eventually will in the next few hours). Looks like they broke their SSL certs, so I'm bypassing them for now.
Photo of Stefan Schelling

Stefan Schelling

  • 14 Posts
  • 1 Reply Like
Thanks for your quick reaction, Samuel. I just gave it a try. But somehow it still doesn't work.
E.g. when trying to add this site (https://www.youtube.com/channel/UCLNVO6TQ8vUGiSgVc-7hWiQ), Newsblur still says: "Broken feed (551)"
Photo of Stefan Schelling

Stefan Schelling

  • 14 Posts
  • 1 Reply Like
Sorry to bother you again. But the Youtube feeds are still very buggy in Newsblur, im still geting a lot of "Broken feed (551)" errors and / or the feeds are not loading at all. Feedly imports them without problems, therefore I'd say that it is not a local problem of mine. Especially since it doesn't work in any of my browser (FF, Chrome, Edge)

Can you have a look at it again, please, why most of hese feeds are not loaded. Thanks!

<opml version="1.1">
  <body>
    <outline text="YouTube-Abos" title="YouTube-Abos">
      <outline text="Jesús Amaya Guitarra" title="Jesús Amaya Guitarra" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCQUUysbbowBlnmL4XF5fQQw"; />
      <outline text="Clint Rauscher" title="Clint Rauscher" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCjn2RkLv9YffF5WnwWpo5SA"; />
      <outline text="Michael Nyman" title="Michael Nyman" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCCAuVN4JcLYNaG7b-XEPaYw"; />
      <outline text="Tango Argentino Köln Tango" title="Tango Argentino Köln Tango" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCHlOM4NDAH0hHM3IyNyrnOA"; />
      <outline text="Sgrammaticando" title="Sgrammaticando" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCN5zwIR-N3WitHgyBrRPbfQ"; />
      <outline text="ThePTVGroup" title="ThePTVGroup" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCiioH25tZ_w447aGN9fRb0g"; />
      <outline text="Ludovico Einaudi" title="Ludovico Einaudi" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCQxsahIsaO7_nDwVlFRMQiA"; />
      <outline text="Deutscher Alpenverein (DAV)" title="Deutscher Alpenverein (DAV)" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCLNVO6TQ8vUGiSgVc-7hWiQ"; />
      <outline text="PTV Smartour" title="PTV Smartour" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCJ_iYMlmIzuWimLlcvcWJgw"; />
      <outline text="MichaelNymanRecords" title="MichaelNymanRecords" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCbSPJdl4yIbYZS0MD_Pvldg"; />
      <outline text="The Jezabels" title="The Jezabels" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCFdgWifhQ3COhLLujLHK0Dg"; />
      <outline text="PTV Vision" title="PTV Vision" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UCmXYE91X7ROXU10zgD3Ag5g"; />
      <outline text="PTV Map&amp;Guide" title="PTV Map&amp;Guide" type="rss" xmlUrl="https://www.youtube.com/feeds/videos.xml?channel_id=UC09fqoXU9moUocftVLLTctA"; />
    </outline>
  </body>
</opml>
Photo of Stefan Schelling

Stefan Schelling

  • 14 Posts
  • 1 Reply Like
As Samuel wrote in this other thread, he now fixed the Youtube based problems on his side. Well done, Samuel, thanks for fixing this. Works like a charm now!