Click on everything, start fetching stories, entire screen goes blank?

  • 8
  • Problem
  • Updated 8 years ago
This behaviour only occurs when I am logged in. If I follow the reproduction steps after logging out, the sample feeds etc all behave properly.

I am reasonably confident that this behaviour did not occur yesterday as late as 5pm Eastern.

I am running OS X Snow Leopard, with all updates applied. I can reproduce this behaviour in Safari Version 5.1.1 (6534.51.22), Chrome 15.0.874.120 and FireFox 5.0.1.

Steps:
1) I log in.
2) I click "Everything" in the left-hand frame.
3) The bottom frame opens, and the "Fetching Stories" and "Counting is Difficult" progress bars start filling. After perhaps a second, the entire screen goes blank.

So far I have been able to read my feeds individually so I can work around the problem.
Photo of Rob Drimmie

Rob Drimmie

  • 7 Posts
  • 0 Reply Likes
  • very mildly put out

Posted 8 years ago

  • 8
Photo of Kazriko

Kazriko

  • 2 Posts
  • 0 Reply Likes
I ran into this with Firefox 7.0.1. I went through my feeds in the folder that was causing the problem one at a time and found that it was the feed from Saturday Morning Breakfast Cereal that was jamming it up. Once I marked it as read, everything worked again.
Photo of Rob Drimmie

Rob Drimmie

  • 7 Posts
  • 0 Reply Likes
Awesome, thanks for finding that. I was working through my feeds but hadn't gotten to SMBC yet. Better be a good one today, breaking my service!

Marking it as read corrected my display issues as well.
Photo of init2null

init2null

  • 6 Posts
  • 0 Reply Likes
I'm having the same problem with SMBC on Firefox 8 and Chrome. I first experienced the bug this morning.
Photo of dcsohl

dcsohl

  • 45 Posts
  • 9 Reply Likes
Same here. I was about to file a report myself, but then thought it might be something about my workplace firewall and decided to hold off til I could test at home.

It's definitely caused by SMBC. That feed contains Javascript in the feed itself, which makes me suspicious of it... I don't know if it had Javascript before today or not.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Yup, this is a direct result of allowing Flash movies in the Feed. Now JS is being executed. What I need to do is strip all script tags, hoping that the sites are using object and video tags. I'll get to this promptly tonight.
Photo of dcsohl

dcsohl

  • 45 Posts
  • 9 Reply Likes
Out of sheer curiousity, I replicated this and then did "inspect element" with Firebug on the blank page. Here's what I got:

<html>

<head>
<script type="text/javascript" src="http://www.google-analytics.com/ga.js">
Reload the page to get source for: http://www.google-analytics.com/ga.js
</script>
</head>
</html>


The relevant lines of JS from the SMBC feed are

var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");

document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));


I don't know why this is having the effect it's having, though.
Photo of ntalan

ntalan

  • 5 Posts
  • 1 Reply Like
I don't subscribe to SMBC, but what happens is after a while my feeds don't load at all. I've found a workaround that sometimes works (click on the top level folder) to view all unread in that folder, and then click on the feed, and it sometimes loads. But the only thing that gets the feeds to load for good is to log out and log back in. And then, at some point later on, the feed won't load. Maybe a different issue...?
Photo of EKM

EKM

  • 22 Posts
  • 2 Reply Likes
I am having the same issue where I click on a feed and it will load but then the whole screen will go blank. I am pretty sure this is related to the javascript in the feeds now. By the way, I love having the feature and it improved my feeds since the audio/video is now embedded. There have been more issues since then though.

The feed I am having trouble with is one of my Huffington Post feeds. I am not sure what the actual link is though.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
OK, I just pushed out a fix for this. I'm not sure if this will correct old stories, but new stories should no longer have this issue.

The fix was to start sanitizing HTML again, but preserving object, embed, and params, which are necessary for Flash videos. Please, please, please let me know if you still have any issues. Note that this will take an hour or two to work through all of your feeds, and then it may or may not fix feeds to correctly display content again. Based on what should be happening, the blank screening should no longer happen, but videos may no longer appear if they are from the past day or two. New videos will work, and no more white screening. Keep me updated with what happens for you.

And if you want to instantly fix a feed, just use Insta-fetch stories.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
And I specifically checked SMBC. I had to erase the Nov. 15th comic, unfortunately, but else all is well.
Photo of Benoît Zugmeyer

Benoît Zugmeyer

  • 2 Posts
  • 0 Reply Likes
Another issue concerning feeds sanitizing :

When you have a &amp;lt; in the XML, it appears to be decoded twice, so "&amp;lt;Sam&amp;gt;" is interpreted as a html tag "<Sam>" instead of "&lt;Sam&gt;". So "<Sam>" is not displayed.

Cf this feed : http://feeds.feedburner.com/bashfr

Thanks for your great work !
Photo of graphain

graphain

  • 10 Posts
  • 0 Reply Likes
Getting the same issue today (at least I think so, when I click everything it starts loading the status bar then stops and says "oh no an error occurred"). The screen remains blank and I don't get to see any feeds.

After going through every one of my feeds one by one I discovered it is http://spacecollective.org/recent and after marking this site as read everything worked again.

Just thought I'd note it.
Photo of graphain

graphain

  • 10 Posts
  • 0 Reply Likes
Just for reference I'm pretty ambivalent about this feed in particular, but if it's useful to resolve issues for others thought I'd mention it.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Thanks for finding the blog! I'm going to add it to my watch list and see if I can figure out a systematic way of stripping out the bad parts of the feed (which is causing the white-screening).
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Correction, not white-screening. Instead, it looks like there is a parse error with the content. Nuts.