Command/ctrl-click doesn't respect open in new tab settings

  • Problem
  • Updated 2 years ago
If you command/ctrl (depending on platform) click on a link in a newsblur story, it should respect your browser's settings for whether to open that link in a tab in front of / behind the current one. It feels like currently newsblur is hooking all click events and applying its own target to the link first.

Easy fix is generally to check whether a modifier is being held down in the click handler and just not do anything in that case.
Photo of David Lynch

David Lynch

  • 14 Posts
  • 1 Reply Like

Posted 2 years ago

  • 7
Photo of David Lynch

David Lynch

  • 14 Posts
  • 1 Reply Like
Though I do note that middle-click works fine. Alas, this doesn't help much when on my laptop.
Photo of mgeraci

mgeraci

  • 37 Posts
  • 12 Reply Likes
You can change this behavior in NewBlur's settings. Just click the gear icon in the lower left of your screen and click Preferences. Then click on the Stories tab and change the "Open links" setting to your preference. Enjoy!
Photo of David Lynch

David Lynch

  • 14 Posts
  • 1 Reply Like
That setting doesn't actually change this behavior -- it's for unmodified clicks.

Try ctrl/command-clicking a link in this window. Unless you've changed your browser default settings, it should open in the background.

Then try doing the same in a story on newsblur. It'll open in the foreground, switching focus from newsblur.
Photo of

  • 4 Posts
  • 1 Reply Like
Command-click for me opens all links on Newsblur in the background - both stories itself and links within the stories.
Photo of David Lynch

David Lynch

  • 14 Posts
  • 1 Reply Like
Interesting! I wonder what's different about our experiences.
Photo of David Lynch

David Lynch

  • 14 Posts
  • 1 Reply Like
Aha! It works properly in Chrome, and behaves as I see it in Firefox.
Photo of

  • 4 Posts
  • 1 Reply Like
I'm using Safari, and it's working for me.
Photo of David Lynch

David Lynch

  • 14 Posts
  • 1 Reply Like
I'd hypothesize that it's "works in Webkit", then.
Photo of Todd Tyler

Todd Tyler

  • 1 Post
  • 0 Reply Likes
I can confirm that this bug still affects Firefox 21, but it works properly in Safari 6.0.4. I am running OSX 10.7.5.
I just started using NewsBlur and it seems like a great replacement for Google Reader!
Fixing this bug would make it perfect!
Thanks!