Email newsletters: HTML rendered as plain text

  • 1
  • Problem
  • Updated 3 months ago
I've noticed some email newsletters being rendered with HTML tags as plain-text content, but the newsletter from GOG.com is particularly curious.

The footer for each of their emails has the line "GOG.COM © 2016. PART OF CD PROJEKT GROUP." (note that none of that is a link)

"Show Original" from gmail has this markup:

<div class=3D"em_text_wrapper em_text_808080 em_text_12 em_header" styl=
e=3D"font-family:Helvetica,Arial,sans-serif;font-style:normal;font-weight:1=
00;margin-top:0px;margin-bottom:0px;margin-right:0px;margin-left:0px;paddin=
g-top:0px;padding-bottom:0px;padding-right:0px;padding-left:0px;color:#8080=
80;font-size:12px;line-height:16px;text-transform:uppercase;"><span class=
=3D"em_link_fix_808080">GOG.com &copy; 2016. Part of CD PROJEKT group.</spa=
n></div>
ie a DIV, a SPAN, and a bunch of inline styles, but no A tag. And yet, in Newsblur's Newsletters folder, "GOG.com" is being wrapped in html... except it's rendering as plain text (see the attached screenshot)
<A HREF="HTTP://GOG.COM"; REL="NOFOLLOW">GOG.COM</A> © 2016. PART OF CD PROJEKT GROUP.


Is Newsblur trying to wrap the domain name in a link tag?
Photo of DMack

DMack

  • 74 Posts
  • 18 Reply Likes

Posted 12 months ago

  • 1
Photo of Rod

Rod

  • 2 Posts
  • 0 Reply Likes
Help! I have the same problem, in my case many of my forwarded e-mails show up in plain text. I can't read my newsletters anymore :(( Did you find a solution to the problem?

(Edited)
Photo of DMack

DMack

  • 74 Posts
  • 18 Reply Likes
I haven't heard anything about my issue, but I'm still noticing it. Mine is even weirder because it's showing through with mostly HTML, but something is injecting plain-text HTML in there where it doesn't belong (not present in the original message)
Photo of Rod

Rod

  • 2 Posts
  • 0 Reply Likes
Let's hope Samuel sees this and can give us some information about the problem.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6367 Posts
  • 1449 Reply Likes
I'm doing a fair bit of sanitizing on the emails and that's causing issues in some emails. But the vast majority of emails are turning out correctly. I'm afraid that this is as error prone as the Text view is, which is to say it works well for most people but there are some websites and some emails that just won't work without changes on the publisher's part.
Photo of DMack

DMack

  • 74 Posts
  • 18 Reply Likes
Regarding my original issue at the top, though, why are link tags being added by newsblur when the original email doesn't have them?