Embedded videos play automatically

  • Problem
  • Updated 2 years ago
Whenever an item has an embedded video, it seems to play automatically. This has happened on multiple occasions. How can this be stopped? My browser is Google Chrome version 28.0.1500.72 m,
Photo of Michael BelayMB

Michael Belay

  • 0 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 7
Photo of Erika JurneyEJ

Erika Jurney

  • 0 Posts
  • 0 Reply Likes
Here's an example of a post where this happens for me too:
http://www.theatlanticwire.com/entert...
from
http://feeds.feedburner.com/TheAtlant...
Photo of DivinoAG

DivinoAG

  • 36 Posts
  • 15 Reply Likes
This is a problem with specific video providers, not with the feeds or Newsblur. There's little it can be done except removing all Flash content from feeds (which would be a big problem for most users), or finding out which providers cause problems and adding a feature on Newsblur to remove them manually. Neither cases are really feasible.

Videos in general tend to make navigating slower, so what I tend to do is just set my browser (Chrome) to block plugins to be loaded by default, so any Flash content requires a click to enable them manually. I find that to be ideal to me: I make navigation faster by not requiring the browser to load plugin content I might not actually want to watch, and stops rogue content from playing without my direct permission.
Photo of Paul Dettmann

Paul Dettmann

  • 3 Posts
  • 0 Reply Likes
it never happened in google reader. at least not until that feed was scrolled over. so, yes, it is a newsblur problem!
Photo of DivinoAG

DivinoAG

  • 36 Posts
  • 15 Reply Likes
It did happen on Google Reader, I had many feeds that caused that. The same feeds do it on Newsblur. The difference is that Newsblur loads more feed items at once if I'm not mistaken, while Google Reader only loaded 10, so maybe you just got to the item faster before it started playing.

But as I pointed out, that is a problem with the video, not the news reader. There's nothing Newsblur can do if the feeds just have bad content. You cannot control how your feed provider will add content to their feed. If they add auto-playing video or audio, broken HTML or content with inline formatting that breaks up when viewed on a feed reader, there's little that can be done on the news reader side. This is like complaining to the company that builds your TV set because there's too much violence on a show you're watching.

What you can do is get in contact with the website that provides you with that feed and ask them to stop adding auto-playing videos to their content, as even on the website proper this is really bad practice, and can make even otherwise innocent websites become NSFW since you lose control over what your speakers will be blasting off out of nowhere. And you can prevent all videos from auto-playing on Newsblur by using the feature I mentioned about, which exists in different forms on pretty much all browsers.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 5411 Posts
  • 1206 Reply Likes
You probably want to switch to List view, which only loads the current story.
Photo of Paul Dettmann

Paul Dettmann

  • 3 Posts
  • 0 Reply Likes
List view only shows the headline, not a preview or any pictures from the story. That is not a solution.
Photo of Erika JurneyEJ

Erika Jurney

  • 0 Posts
  • 0 Reply Likes
An ideal solution IMO would be to make a setting which would disable flash and use whatever technique this chrome extension uses:

https://chrome.google.com/webstore/de...

Note that this doesn't work for newsblur.com - I assume this is because the sites' content is in an iframe.

(Edited to add: I love newsblur, by the way!)
Photo of DivinoAG

DivinoAG

  • 36 Posts
  • 15 Reply Likes
You can do that natively on Chrome by going to the Settings, Privacy > Content Settings, and under Plugins, set it to Click to Play.

This will work on all websites, and you can set which domains you want to be exempt from this rule (Youtube.com is a good one to keep always on). If you don't add Newsblur to the whitelist, videos from any sources will not auto-play.
Photo of Erika JurneyEJ

Erika Jurney

  • 0 Posts
  • 0 Reply Likes
Thanks for the great tip - works perfectly!
Photo of Paul Dettmann

Paul Dettmann

  • 3 Posts
  • 0 Reply Likes
How about not loading any of the content of feeds far down the list that I have not scrolled to yet. I'm pretty sure I never had this problem in Reader. Videos might have played when I actually got to that feed, but not before. I don't remember ever having to stop reading whatever feed i was on, scroll down past a bunch of feeds I haven't gotten to yet to find which one was playing a video without my permission, and then scroll back up to find the one I was looking at before I was interrupted.
Photo of DivinoAG

DivinoAG

  • 36 Posts
  • 15 Reply Likes
That's really not a good solution. What makes reading content on RSS readers fast is exactly the fact they pre-load content from the next X items. Remove this, and you kill this app.

As I said, even if you never saw that problem happen on Reader, I had it happen all the time, and used Flash Blocker plugins to prevent that from happening (Chrome didn't have the built-in feature back then). Reader was *the reason* why I started using Flash Blocker. So your experience isn't really proof of this being a problem exclusive to Newsblur, it's just a coincidence.