Feeds not respecting "unread only" flag

  • 5
  • Problem
  • Updated 7 years ago
As time goes on, more and more of my feeds aren't respecting the "all stories" versus "unread only" toggle. Since I usually read oldest first, that means I get a feed that shows 2 week old messages until I scroll down and slowly reveal the new unread content at the end of the feed. And different from the usual complaint, the stories are getting marked as read just fine so my feed statuses are current, they're just displaying last week's news when they shouldn't.

If I switch sort order to newest first, I at least see the new stories at the top, but then I tend to read stuff out of order.

This seems to be happening on live and dev as of 8:30am central, 1-apr-13.

Specifically: engadget, joystiq, the unofficial apple weblog. Note that they're all AOL feeds apparently. It looks like I'm using the current preferred feed URL for all three
Photo of Patrick Friedel

Patrick Friedel

  • 4 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 5
Photo of rdominick

rdominick

  • 28 Posts
  • 8 Reply Likes
I had this happening in a few feeds. What I did was, I read the new stories in the feed and then used "Mark All As Read". Now the feeds don't show the older, already-read articles any more; they work as you'd expect.
Photo of Patrick Friedel

Patrick Friedel

  • 4 Posts
  • 0 Reply Likes
Hrm. Good idea and I just tried it, but they're still showing the old already read items despite the feed being set to show unread stories only. I've even tried toggling the all/unread option back and forth to see if some request timed out and is preventing the status from being updated.
Photo of shawnduffy

shawnduffy

  • 3 Posts
  • 0 Reply Likes
I'm having this same problem. Boing Boing was like this but it's now working properly. But I still have this issue with TechCrunch and The Verge.