Hotkeys "o" and "v" no longer open tabs in the Background in Chrome

  • 16
  • Problem
  • Updated 4 years ago
Since I upgraded Chrome to 41.0.2272.16 beta (on Linux) the hotkeys "o" and "v" no longer spawn new tabs in the background but focused tabs.
Photo of Jürgen Geuter

Jürgen Geuter

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 16
Photo of Darren Kay

Darren Kay

  • 68 Posts
  • 19 Reply Likes
Might be a chrome update that broke this but cannot find details if such a change in release notes so far.
Photo of Andrew Churchill

Andrew Churchill

  • 2 Posts
  • 1 Reply Like
Experiencing this on Windows 7 as well running Chrome 41
Photo of ravenel

ravenel

  • 11 Posts
  • 6 Reply Likes
Also believe this is related to a Chrome update. Having this problem as well on one machine running Chrome 41 beta; another running Chrome 39 is still working as previously. Would love to understand how to resolve this one way or another.
Photo of Alex Paterson

Alex Paterson

  • 10 Posts
  • 1 Reply Like
I'm using Chrome too and am having this issue. However, I also tried it in Firefox and the tabs aren't being opened in the background there either.
Photo of Shrike

Shrike

  • 14 Posts
  • 3 Reply Likes
Opening tabs in the background via hotkey has never worked on Firefox.
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
With Firefox, I think setting the about:config setting for "browser.tabs.loadDivertedInBackground" to true should still work.  I haven't tried it in a few years though.
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
Hi guys,  

Two years ago, I made a Chrome extension to solve this issue.  I didn't do much work on it due to lack of feedback and because it was implemented on Newsblur's side fixed the issue.  I just tried Chrome 41 and ran into this problem.

It appears that my extension still works, and I just tested it on Chrome 41 on Windows.  I'll try to update it and put it on the Chrome Extension store within a few weeks.

It's available in my GitHub account, though you'd need to load an unpacked extension in Chrome.

https://github.com/Lyrrad/NewsBlurBackgroundTab

Right now, all it does is add a hotkey for ";" to open in a background tab.
Photo of Ron Gilbert

Ron Gilbert

  • 3 Posts
  • 0 Reply Likes
I observe the same misbehavior on Chrome 41.0.2272.74 beta (64-bit) and Firefox 33.1.1 on the Mac. Safari handles the 'o' key correctly.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Thanks Darryl! I linked to your post on the twitter account so that other folks may get some use out of your wonderful extension.
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
I've uploaded it to the Chrome Web Store and renamed it to "Background Tab for NewsBlur".  I assume this is the proper way to describe an unofficial extension.  

https://chrome.google.com/webstore/detail/ieeimmkgocgaaabphkgjdkophaejfnlk/

I'll add this link to the GitHub page and release the extension under the GPL shortly.  I'll look into updating the functionality soon as well.

My Twitter handle is @darryltam
Photo of Brent Nordquist

Brent Nordquist

  • 6 Posts
  • 0 Reply Likes
Thanks Darryl for creating that! When I upgraded to Chrome 41 (Mac) "o" stopped opening stories as a background tab; using your extension and ";" works.
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
I've updated the extension to fix some bugs.  I also got some pull requests to improve it so that the new tab opens next to the NewsBlur tab.

I spent a few hours trying to figure out how to override the 'o' and 'v'  NewsBlur hotkeys from a Chrome extension, but I've been unable to figure it out.  This would be useful so that I could optionally bind the extension to the default background tab key.

Do you think it's possible to add an option to disable the 'o' and 'v' hotkeys?  I guess that's related to the custom keyboard shortcuts feature, though I just see a mention of that upcoming feature from two years ago.
Photo of Christian Bering

Christian Bering

  • 9 Posts
  • 1 Reply Like
It's great that there is an extension to fix this bug, but is there any chance to fix the original bug?

Also Darryl: any chance to add the option of choosing another key in the extension? I am on a non-US keyboard where I have to hold down SHIFT to press ;
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
I don't think the original bug can be fixed. Chrome has disabled the ability of webpages to open background tabs directly.

I've developed an options page to customize the hotkey.  I'll test it out some more before pushing it to the web store version.
Photo of cjrecord

cjrecord

  • 32 Posts
  • 1 Reply Like
So much looking forward to this - I've gotten so used to 'o' to open the background tab that I keep confusing myself...
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
I should have an updated version within an hour or so after I complete testing (Version 4.0.0).  Someone figured out how to override NewsBlur's hotkeys, so I should be able to restore the original functionality almost completely.  (I think the tab order might be slightly different)

Edit: The updated extension should now be live.
(Edited)
Photo of Rémi Carayon

Rémi Carayon

  • 1 Post
  • 0 Reply Likes
Please fix this, it's really annoying and i don't want to do things like enable dev mode and i don't know what else.

Please.
Photo of ravenel

ravenel

  • 11 Posts
  • 6 Reply Likes
It's not a bug that can be fixed--Chrome itself changed the way background tabs work. There's a plugin in this thread that may help you.
Photo of Brent Nordquist

Brent Nordquist

  • 6 Posts
  • 0 Reply Likes
Just a data point for you Darryl: I have Mac Chrome 41.0.2272.89 (64-bit) ... the extension worked for a few days, and yesterday mysteriously stopped working. I restarted Chrome and it autoupdated the extension to 0.3.0, and I double-checked in Options that the hotkey is set to ";" but it still isn't working. Not sure if there's something else I should try?
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
Hmm.. that's not good.  I'm not experiencing this issue.  Are you using a non-US Keyboard layout?  I only updated it to 3.0 a few hours ago, so this issue would have been present before then.  Does switching to a different keyboard shortcut have any effect?

I did add some exclusions so that it wouldn't work if the focus was in a text area, or if there was an overlay from NewsBlur from a menu of some sort.

You could also see if there are any errors that appear in the Javascript console (View->Developer) when you try to open a new tab.
Photo of Brent Nordquist

Brent Nordquist

  • 6 Posts
  • 0 Reply Likes
HA! Of course, I turn on the JS console, and now ";" works. :-) It still works with the console turned off, and I can't reproduce it.

I'll keep watching to see if this resurfaces, and if so, see if I can isolate what's making it happen. Thanks for the notes and ideas re: focus and overlays; that gives me something to look for. (I'm just using the regular US keyboard layout.)
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
If the settings (e.g. hotkey) change, or the extension is disabled and reenabled, the NewsBlur page will need to be reloaded for the hotkey to work again.  Let me know if it happens again, though.
Photo of Brent Nordquist

Brent Nordquist

  • 6 Posts
  • 0 Reply Likes
OK, it happened again, and I could see an error in the JS console:

"Uncaught error: Error connecting to extension"

But, then I noticed the extension had upgraded to 0.4.0, which is probably why it couldn't connect to it. So I reloaded the NewsBlur tab, and voila, "o" opens to background again. Well done!

I think this might be what happened to me last time. I thought I had reloaded Chrome and/or the NewsBlur tab after it upgraded to 0.3.0, but maybe I got the order wrong. I would disregard the issue I've reported... if I see it again, unrelated to an extension upgrade, I'll diagnose and let you know. Reloading after upgrade is a small price to pay. Really appreciate your creating this extension Darryl!

(Are the new extension options supposed to be editable? I have a pair of checkbox-and-text-field for each key, but I can't toggle the checkboxes or type anything in the text fields.)
Photo of Darryl

Darryl

  • 15 Posts
  • 12 Reply Likes
Hmm.. it should be editable.  I'll do some further testing.  I'm using some JavaScript to enable and disable those fields, so there might be a bug there.  I know I still need to be able to grey out the text next to the checkboxes and text fields, which I'll do soon.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
I added this Chrome extension to Goodies. Check Manage > Goodies if you forget about this thread.
Photo of Adam Maisel

Adam Maisel

  • 2 Posts
  • 0 Reply Likes
The extension has been working perfectly for the past six months, but today when I started up Chrome (version:  45.0.2454.101 m) the extension no longer seems to be working.
Photo of cjrecord

cjrecord

  • 32 Posts
  • 1 Reply Like
I'm running the 64-bit version of that and it's fine? Another extension interfering?
Photo of Adam Maisel

Adam Maisel

  • 2 Posts
  • 0 Reply Likes
Didn't change my extensions recently but I just reset the computer and it appears to be working properly again