Items not staying marked as read

  • 95
  • Problem
  • Updated 6 years ago
This may be a problem related to too many new users, etc, etc, but some of my feeds that are more active than others have had their items marked as un-read many times. For example, I'm currently looking at a feed where the oldest "new" item is from yesterday at 4:39am. I've marked this feed as read MANY times since then, but they keep coming back!
Photo of crazydog115

crazydog115

  • 3 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 95
Photo of thebassman

thebassman

  • 14 Posts
  • 1 Reply Like
Yeah, I'm still experiencing the same problem...
Photo of Matthew Dharm

Matthew Dharm

  • 24 Posts
  • 2 Reply Likes
I wasn't seeing this before, but now I am. Username 'matthewdharm' and I'm using dev.

If I select my XKCD feed (unread-newest) I see 3 stories which are all marked as read.

If I select "All Site Stories", I see 3 unread stories from the XKCD feed.
Photo of Gary Pendergast

Gary Pendergast

  • 4 Posts
  • 0 Reply Likes
Yeah, xkcd just started doing this for me, too.

https://dev.newsblur.com/site/169/xkc...
Photo of tedder42

tedder42

  • 149 Posts
  • 11 Reply Likes
arstechnica just got unmarked. at least the second time since "solved".
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Tedder, I'm using your account to test things. Next time it happens, email me immediately. samuel@newsblur.com. I just checked and everything works perfectly with Ars Technica on your account.
Photo of Matthew Dharm

Matthew Dharm

  • 24 Posts
  • 2 Reply Likes
Try my account (matthewdharm) on my XKCD feed; it's happening right now.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Sorry Matthew, I have special logging setup for Tedder. If it's happening for you, just insta-fetch the stories. That will resync the feed. If I find out what's happening, I will resync all of the affected feeds manually.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Ok Matthew, I synced your reads as well. Let me know if it shows up again.
Photo of Robert Ewing

Robert Ewing

  • 4 Posts
  • 2 Reply Likes
Having this problem still - LifeHacker and The Verge - All this morning.

(User name rewingau)
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Synced your reads on The Verge. Let me know if it shows up again on that feed.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
OK, I'm really happy with the fix, so what I need now is for anybody on this thread to provide a list of feeds (specifically I need the NewsBlur URL, which has the numeric feed id in it --- /site/feed_id/title) that are still giving you guff. I manually synced The Verge, Ars Technica, RRW, and Boing Boing. Happy to do any more.

Also, this bug will be automatically purged throughout the system in two weeks, so if you do nothing, all of your troubles will be gone in 14 days (and undoubtedly sooner for most stories) as the missing read story markers disappear.
Photo of onkelpuck

onkelpuck

  • 34 Posts
  • 6 Reply Likes
As of today I am having a wrong unread count in daring fireball:
when clicken "All site stories"

http://dev.newsblur.com/site/3/daring...

and Kottke

http://dev.newsblur.com/site/39/kottk...

has been showing me posts all over as well
Photo of Maulkin

Maulkin

  • 3 Posts
  • 0 Reply Likes
Also an issue for me (maulkin) with https://dev.newsblur.com/site/1503698...
Photo of Thebudac

Thebudac

  • 9 Posts
  • 1 Reply Like
Still have the same unread items as yesterday.
Photo of Thebudac

Thebudac

  • 9 Posts
  • 1 Reply Like
No change.

Have read, marked read, instafetched, deleted, re-added and scrolled past these same items from lifehacker and failblog for 10 days now on chrome plugin, ios and Android. No change.

Will log in again in 2 weeks to see if the fix you claim has done what it is supposed to. Can't use that feeling a bit pissed that I had to pay to find out it doesn't work. Will see in 2 weeks and then I'm probably going to start talking about wanting my money back.

Photo of Kádár Tamás

Kádár Tamás

  • 53 Posts
  • 6 Reply Likes
Just happened to me with penny arcade and the savage chicken.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
If you want to speed up the 2 week fix, just mark the individual feed as read. Before you do that, if you want to see if the fix will work, mark a broken story as unread and then read again, then reload the feed. If it's gone, then marking the feed as read should fix the whole thing.
Photo of Thebudac

Thebudac

  • 9 Posts
  • 1 Reply Like
Vastly improved now. Thanks. System is no quite usable.

Still a few feeds that pop up as unread after reading but they very much fit your FAQ write up since they are smaller less popular

https://www.newsblur.com/site/7599/ba...

was the last one.
Photo of Thebudac

Thebudac

  • 9 Posts
  • 1 Reply Like
*"now quite" not "no quite",
Photo of alxndr

alxndr

  • 59 Posts
  • 7 Reply Likes
Happening to me with a feed that gets perhaps a dozen new items per day.
Photo of Greg

Greg

  • 10 Posts
  • 0 Reply Likes
This seems to be fixed now for feeds, but now I've got something in one of my friend's feeds (http://www.explosm.net/comics/3137/, specifically) that always shows up as unread, even though I've read it a hundred times. I've tried clicking the Mark All Read button, and it still doesn't change. I can't get rid of it at all.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Yeah, Explosm has had problems, and it's because they have something funny going on with their feed. There's a thread dedicated to them, actually.
Photo of Neil

Neil

  • 4 Posts
  • 0 Reply Likes
I had this happen this morning with my feed for The Trenches (http://trenchescomic.com/). I had two items, marked them as read (by double-clicking on the 2 in the left-hand column), and continued reading. A few minutes later, the 2 unread returned.
Photo of Ryan Nobles

Ryan Nobles

  • 8 Posts
  • 0 Reply Likes
I have a couple of items from edmunds.com that won't go away as well.
Photo of Chris Hubbs

Chris Hubbs

  • 8 Posts
  • 0 Reply Likes
This item from Kottke won't go away seemingly no matter how many times I mark it read:

http://kottke.org/13/04/updates-on-pr...
Photo of Tom Dillon

Tom Dillon

  • 1 Post
  • 0 Reply Likes
When I read stuff on the Android app, most of the stuff is back as unread when I next open the app (or just refresh the feeds). I haven't been making notes of which feeds in particular it has been happening to, as it seems to be all of them.
Photo of ojiikun

ojiikun

  • 475 Posts
  • 62 Reply Likes
You'll be pleased to know that quite a bit of code to fix the Android-specific flavours of this bug was submitted just yesterday. Look out for the next release of the app!
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Just submitted the latest app, so it'll take a couple hours to get to your device. Let me know if it works.
Photo of Neil

Neil

  • 4 Posts
  • 0 Reply Likes
I'm still seeing this happen quite frequently. Any updates?
Photo of irunfrombears

irunfrombears

  • 1 Post
  • 0 Reply Likes
This seems to happen on all of my feeds. I'll mark as read but then as soon as there is a new item all those unread items will show up as new again.

Username is irunfrombears.
Photo of 2nerdscom

2nerdscom

  • 13 Posts
  • 1 Reply Like
Since the "upgrade" this is happening on many of my feeds now. I keep seeing the same items over and over again.
Photo of ravenel

ravenel

  • 11 Posts
  • 6 Reply Likes
Seeing this happen quite a bit on the upgrade as well. Oddly, it wasn't happening on the dev server yesterday, so it appears to be a very recent problem.
Photo of Chuck Lane

Chuck Lane

  • 15 Posts
  • 0 Reply Likes
Im guessing this is a back end issue as I keep seeing 403 and 404 flashing in the header when things dont get marked as read?
Photo of ravenel

ravenel

  • 11 Posts
  • 6 Reply Likes
Could be--I'm also seeing a few "Newsblur is down" issues when loading feeds, so I wonder if some service is overloaded or something.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Sorry about that folks. One of my app servers was down and HAProxy just kept serving requests to it. In other words, 1 out of every 12 requests would fail. Ugh.
Photo of Pedro Côrte-Real

Pedro Côrte-Real

  • 9 Posts
  • 0 Reply Likes
The frontend should probably keep track of that and reissue those calls. Otherwise any network error is going to cause the same problem.
Photo of ravenel

ravenel

  • 11 Posts
  • 6 Reply Likes
Ah, that makes a lot of sense given the types of symptoms I was seeing. Thanks for getting it fixed up!