Loading, loading, loading...

  • 1
  • Problem
  • Updated 5 years ago
When clicking a feed, they appear to be continuously loading and stories are not shown. This happens on both FF and Chrome, but IE works fine. Clearing cache/cookies doesn't help.
Photo of RackDaddy

RackDaddy

  • 8 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of RackDaddy

RackDaddy

  • 8 Posts
  • 0 Reply Likes
This error may have been a result of AdMuncher blocking necessary elements of Newsblur. I've whitelisted the site, and things seem to be working better.. I'll report back if the problem resurfaces.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Yes, this is a known issue with ad blockers. I wish there was an easy way to identify that an ad blocker is making NewsBlur unusable.
Photo of Carol H Tucker

Carol H Tucker

  • 17 Posts
  • 1 Reply Like
The problem was apparently resolved last night but it took about two hours for NewsBlur to start working.   And now it is failing once again to load -- was working fine and just stopped.  Seriously?
Photo of wzol

wzol

  • 40 Posts
  • 11 Reply Likes
Somewhere read a trick for this. Create a "bait" for ad blockers: a 468x60 sized div, class="advertisment", and add some string into it. Move it off-screen. If there is an ad-blocker it will be hidden, or the div, or its content will be removed - which you can check from javascript - never tested, but seems ok.
Photo of RackDaddy

RackDaddy

  • 8 Posts
  • 0 Reply Likes
@Sam, it appears to be Google Analytics causing the issue, as its the only thing appearing in the log:

Default filter match - Block retrieval of URL: .google-analytics.*.js [http://www.google-analytics.com/ga.js]

Whitelisting it fixes the problem. As a paid member, we shouldn't have to worry about these types of services.

@Wzol, I'll give your suggestion a try.
Photo of Carol H Tucker

Carol H Tucker

  • 17 Posts
  • 1 Reply Like
I am having this problem today 
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
I worked with Carol last night to try and identify the issue. I had her visit a URL like http://www.newsblur.com/reader/feed/870283 and she was unable to load it consistently. Now that's a JSON blob in there, so it's unrelated to anything client-side. It's either the browser or the NewsBlur server, but I monitor the server quite aggressively and they are all in good shape. 

When it's the browser, it's 99% of the time a browser extension, but it could also be your network. Now you also mentioned that this happens at home as well as work, but is it possible you're running a VPN or something that is having an effect on your network?
Photo of Carol H Tucker

Carol H Tucker

  • 17 Posts
  • 1 Reply Like
The frustrating thing is that it will be working fine and then stutter, and refuse to work.  I'll keep an eye out to see if it is always loading the same feed that triggers the issue, there are a couple of feeds that I do not access at work and only look at when home.

BTW, I really appreciate the prompt replies!  Thank you for your time and assistance