my wordpress site feeds are comments only

  • 3
  • Problem
  • Updated 7 years ago
When I add a wordpress blog feed, Newsblur seems to only grab the comments, not the articles.
Photo of jason.koskie

jason.koskie

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 3
Photo of jepler

jepler

  • 9 Posts
  • 4 Reply Likes
When you subscribe to a "web page", newsblur looks through the list of feeds that the page specifies and takes the first one. Unfortunately, many blogs including wordpress place the 'comments' feed first and the 'real' feed in a lower position.

If you use the Firefox browser, you can subscribe to the correct feed by following these steps:
* One time only, on newsblur.com click the gear icon, then "Firefox: Register Newsblur as RSS reader"; approve the addition.
* Go to the front page of the blog you're interested in
* Right click > Page Info (or press ctrl-i)
* Click "feeds", then click on the appropriate feed
* Choose "feedblur" from the "Subscribe to this feed using..." menu if necessary
* Click subscribe
(phew, that was a little bit complicated, wasn't it!)

Other browsers may have a similar sequence of steps, but I'm only familiar with firefox.
Photo of hawkrives

hawkrives

  • 9 Posts
  • 2 Reply Likes
If you look under the Bookmarks menu, the "Subscribe to This Page" option will turn into a menu if the page advertises multiple feeds. A simpler solution is to just pick the feed that doesn't say "comments feed". It should open up in the normal Firefox subscribe dialog, and allow you to follow it.
Photo of jepler

jepler

  • 9 Posts
  • 4 Reply Likes
This is basically the same problem as https://getsatisfaction.com/newsblur/... and there are some other similar reports via search https://getsatisfaction.com/newsblur/... which may contain more tips to help you work around this problem.
Photo of hawkrives

hawkrives

  • 9 Posts
  • 2 Reply Likes
If you look under the "site settings" dialog for the affected sites, a little bit of tinkering with the URL that Newsblur uses for the feed should fix your problem. I had about 15 feeds that switched to their respective comments feeds when I switched; it only took me about ten minutes to fix them.

If you want to reply with an example of one of the URLs, I'll show you an example of a change.
Photo of jason.koskie

jason.koskie

  • 2 Posts
  • 0 Reply Likes
Thanks. I was basically doing this, but it was acting a bit janky in Chrome. Switched to Firefox and the site settings options work well.