newsblur is displaying without styling or javascript working

  • 1
  • Problem
  • Updated 5 years ago
My newsblur has stopped working in Chrome. I have disabled all my extensions just to be sure. The page loads with no styling or javascript. I just see a column of text and occasional image, It still works in Firefox. It worked yesterday. Javascript is enabled (as far as I know). I do not have Norton installed - Joel Gould joelg@alum.mit.edu
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Can you check the developer console to see what's going on with those JS/CSS requests?
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes
This is what the developer console says:

Uncaught ReferenceError: _ is not defined (index):1138
Uncaught ReferenceError: $ is not defined (index):1146

Here is the contents of index starting at line 1137:
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes
Also note that it works from incognito mode in Chrome, and it works in Firefox. And it was working 2 days ago.
Photo of Darren Kay

Darren Kay

  • 68 Posts
  • 19 Reply Likes
"Also note that it works from incognito mode in Chrome" could mean it's an extension. They have to be enabled for incognito mode so the fact it works in that mode would suggest an extension is blocking the web page from loading properly.
Photo of Darren Kay

Darren Kay

  • 68 Posts
  • 19 Reply Likes
I have to disable AdBlock for the newsblur site to work
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes
Enabling or disabling AdBlock makes no difference for me.
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes
If I disable all extensions, it still fails. If I enable all extensions in incognito mode, it still works in incognito mode.
Photo of Darren Kay

Darren Kay

  • 68 Posts
  • 19 Reply Likes
What if you run Chrome with the --disable-extensions command-line option, does that change the way it looks?
Photo of Darren Kay

Darren Kay

  • 68 Posts
  • 19 Reply Likes
Note: you if you have the setting to keep chrome running in background then you then chrome is still running even when you close the browser window. Some chrome extensions require a restart to apply. Kill all chrome.exe tasks or disable the option in settings
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes
Clean reboot (to be completely sure chrome is not running in background).
Double check with System Explorer that no Chrome task is running.
Start Chrome with --disable-extensions.
Problem still occurs.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Ok, since you've been in the dev console, check the network/resources tab, go to JS or CSS and see what error you get for the single JS or CSS file that newsblur uses.
Photo of Joel Gould

Joel Gould

  • 7 Posts
  • 0 Reply Likes
OK. Short answer is that it is working again.

Longer answer, I noticed that both common.js and ga.js returned 304 - not modified. So I cleared the browser cache ... and now it works. The only thing I can hypothesize is that I had a truncated download of one of those js files and that every time I visited the site it though it did not need to fetch it. In incognito mode, it probably did not cache the resources so it refetched it over and over.

Thank you for looking into this. I am happy again.

Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Yep, a 304 with bad data would do that. Use shift+refresh to clear the cache quickly, but I wonder if anybody else has had that issue. Perhaps you loaded the site during a deploy. *gasp*
Photo of Darren Kay

Darren Kay

  • 68 Posts
  • 19 Reply Likes
FYI - for future reference Ctrl+F5 in most browsers forces site to reload without cache