Newsblur won't work on my phone after today's update.

  • 4
  • Problem
  • Updated 5 years ago
This morning Newsblur was working great on my phone, as usual, and I was loving it, as usual. Then I updated, and the trouble began. Now the feeds take an amazingly long time to load, and I can only swipe through two or three items before the whole thing crashes. I would absolutely revert back to the earlier version if I could. I appreciate what you were trying to do, but one of my favorite programs just became unusable.

app version: 4.0.0
android version: 4.4.4
device: motorola XT1053 (MSM8960)
memory: normal
speed: 95 in 223
Photo of stevereally

stevereally

  • 2 Posts
  • 1 Reply Like

Posted 5 years ago

  • 4
Photo of Lucas High

Lucas High

  • 14 Posts
  • 0 Reply Likes
I am having the exact same problem after update. It has become unusable. Crashes as soon as the Newsblur app opens. Is it possible to go back to original version?

app version: 4.0.0
android version: 4.4.4
device: LGE Nexus 4 (MAKO)
memory: normal
speed: 0 in 0
Photo of ojiikun

ojiikun

  • 475 Posts
  • 62 Reply Likes
Make sure you submit crash reports when prompted and we should be able to see them within a day. I will keep an eye out tonight.
Photo of Ahmet A. Sabanc─▒

Ahmet A. Sabanc─▒

  • 11 Posts
  • 1 Reply Like
Having same problems with Samsung Galaxy Grand Quattro with Android 4.1.2

Submitted couple of reports when prompted. Should I submit every time it happens or will these be enough?
Photo of ojiikun

ojiikun

  • 475 Posts
  • 62 Reply Likes
Once or twice is usually enough, though definitely send another if a new version comes out and doesn't fix things.
Photo of Cheng-Jih Chen

Cheng-Jih Chen

  • 7 Posts
  • 0 Reply Likes
I'm having the same problem on my Nexus 7 (1st gen)
Photo of mokelly

mokelly

  • 35 Posts
  • 3 Reply Likes
Same problem on my HTC One (M7). Crash reports sent!
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Just pushed out 4.0.1 which should fix any crashes that were sent our way.
Photo of mokelly

mokelly

  • 35 Posts
  • 3 Reply Likes
I still get frequent crashes with 4.0.1, though less frequent than with 4.0.0.
Photo of ojiikun

ojiikun

  • 475 Posts
  • 62 Reply Likes
Keep the reports coming! There aren't many problematic devices left, and we went after the common crashes first. Any additional info you can provide about ROM or system utilities in use will be helpful.
Photo of Lucas High

Lucas High

  • 14 Posts
  • 0 Reply Likes
Keep getting crashes with 4.0.1. Very buggy, Sending in crash reports. Thanks.

app version: 4.0.0
android version: 4.4.4
device: LGE Nexus 4 (MAKO)
memory: normal
speed: 0 in 0
Photo of Justin W

Justin W

  • 7 Posts
  • 2 Reply Likes
I'm also having a lot of performance issues with this new version along with frequent crashing. I like the idea of offline reading but this implementation seems quite problematic.

-Ever since 4.0 came out the app is very slow to load news feeds and unread items. Based on the status banner on the bottom of the screen it seems like instead of displaying the feed "live" NewsBlur is first caching the feed for offline use and then displaying it. For me this results in a 3-4 second delay before a feed's unread items are displayed, along with another 3-4 second delay when I open a feed item to read.
-Very frequent crashes, usually while swiping between feed items but sometimes also just when opening a single item. I didn't notice much difference between 4.0 and 4.0.1

As I said, I like the idea of offline caching, but these days it's very infrequent that I'm actually without a network connection of some kind. Offline caching should be something that happens in the background (perhaps with a manual 'sync for offline' button in a menu for when you know you're about to go offline). Though if I had to guess I would say this caching change was done as much to help us as it was to help with NewsBlur server utilization.

App Version: 4.0.1
Android Version: 4.4.2
Device: Sony Xperia Z2 (D6503)
RAM: 3GB

Update (2014/11/24): I ended up having to rollback NewsBlur to 3.7.1 with Titanium, version 4 is basically unusable for me at this point. Really hope this gets fixed.