NewsBlur is bad at guessing where moved feeds are

  • 1
  • Problem
  • Updated 8 years ago
It's happened more than a couple of times while I've been using NewsBlur -- a feed has moved, and NewsBlur has seized on the wrong feed to replace it with. This recently happened with the TouchArcade feed. For some reason, it ended up on the podcast-only feed, and I missed days of posts. If the feed address changes without user intervention, we should probably get a notification or a warning that it has happened, and actually, I'd rather just get the exclamation point error and have to manually fix the site.
Photo of rdominick

rdominick

  • 28 Posts
  • 8 Reply Likes
  • a bit annoyed

Posted 8 years ago

  • 1
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
I just changed this about a week ago to no longer try to guess where the feed has moved to if it is a known good feed. Did this happen recently?
Photo of rdominick

rdominick

  • 28 Posts
  • 8 Reply Likes
Yes, on the day I left the report.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Hmm, I no longer save enough history to be able to see anything but 200s. I should probably start saving a lot more fetching history, so I can track down issues like this. I'm going to hold on to feed fetch errors for 2 weeks (as opposed to cleaning them out after 24 hours for efficiency's sake). Committed here: https://github.com/samuelclay/NewsBlu....

I'm not able to do anything about this feed, but if it ever happens again, to you or anybody else reading here, let me know and I'd love to take a look. Sorry I'm not able to figure out what's going on here. You have the Site Settings dialog available to switch the feed over, but I agree, it sucks when it changes out from underneath you. I took steps last week to ensure that this doesn't happen again.
Photo of rdominick

rdominick

  • 28 Posts
  • 8 Reply Likes
Thank you very much for looking into it!