Performance through Google Chrome

  • 3
  • Problem
  • Updated 8 years ago
I've noticed that memory usage is quite high and performance suffers (using Chrome). I've had the site hang my machine a couple of times in the last day. Any ideas? (I have quite a lot of feeds).
Photo of Daniel Woolstencroft

Daniel Woolstencroft

  • 12 Posts
  • 1 Reply Like

Posted 8 years ago

  • 3
Photo of Daniel Woolstencroft

Daniel Woolstencroft

  • 12 Posts
  • 1 Reply Like
Just as an update, after going "end to end" through my feeds for the morning, my Chrome tab's memory usage is 314mb (it started around 40mb before reading any feeds).
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Last time I went through the profiling tool in WebKit (I'm a Safari guy) I tackled any memory leaks. It's possible that some came back, since a lot has changed since then. I'll take a look at it as time allows. I use the site everyday myself, and I haven't noticed any sluggishness, especially as I've kept the site open all day. It helps to refresh occasionally, if only for the fact that I deploy 4-6 times daily, oftentimes with a small tweak or two, and sometimes with a large new front-end feature.
Photo of total deadbeat

total deadbeat

  • 4 Posts
  • 0 Reply Likes
I love the service itself, but it brings my computer to its knees. Maybe the problem's on my end but sometimes if I use NewsBlur and click on 'Everything' everything grinds to a halt and I have to reboot my computer using a hard reset. I think it's a Chrome problem.