PopSci feed severely breaks UI

  • 1
  • Problem
  • Updated 8 years ago
Take this feed http://www.popsci.com/rss.xml and mark just the "aviation" tag as interesting. Then crank the filter up to maximum so that only "aviation" stories show. Two issues occur:

1. The browser becomes unresponsive for something like a minute (latest Chrome on Win7) while the stories are loaded

2. Once loaded, a video overlay remains visible no matter where I browse. It sometimes obscures the left pane, but not always. Here's a screenshot: http://i.imgur.com/Eh6z9.png - the highlighted rectangle has a fixed position, so scrolling up/down only scrolls the text behind it, but not this rectangle.
Photo of romkyns

romkyns

  • 44 Posts
  • 2 Reply Likes

Posted 8 years ago

  • 1
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Thanks for letting me know about this! OK, I just committed and deployed what I hope is a fix. If there are > 100 stories on the page, then animations are disabled when changing the intelligence level.

As for the video, I'm not seeing the issue. The Feed view works great, as does the Original view.
Photo of romkyns

romkyns

  • 44 Posts
  • 2 Reply Likes
I've just made a video of the buggy layout: http://screencast.com/t/vhuZvW9p

After changing the intelligence level, Chrome started using my entire CPU while loading stories, so I guess the CPU usage is due to something else.

The broken layout starts at 0:40 in this video. At 1:07 it becomes apparent that this rectangle is showing the flash plugin with a video. It can even be played. This issue occurs on two Windows computers using Chrome (no addons).
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Ah-ha, it's because there are so many stories on the page, all loading video. By my count, it was way more than 100 videos on the page (even though many of them were hidden, that's still dozens of videos being loaded).

I could change the embed to not actually embed the enclosed mp3 or video, but to show a button that allows you to play it. It wouldn't be a difficult change, although it seems like it would make it a pain if you do a lot of reading through enclosures. You'd have to click a button to even be able to then hit play. What do you think?
Photo of romkyns

romkyns

  • 44 Posts
  • 2 Reply Likes
That might explain the browser becoming unusable!

I think the button is an acceptable stopgap, especially since the feed is currently completely unusable.

Maybe when you have some spare time (haha) you could add some javascript that would automatically load the enclosure only when I scroll to it? Some websites do this for images, presumably to save bandwidth. Though I personally don't mind the button that much.