Reddit feed only ever gets updated if I manually do an insta-fetch on it.

  • 1
  • Problem
  • Updated 7 years ago
This RSS feed only ever gets updated if I manually do an insta-fetch on it: http://www.reddit.com/r/tabled/.rss
Photo of ecognito

ecognito

  • 21 Posts
  • 5 Reply Likes

Posted 7 years ago

  • 1
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Right click on it and go to Statistics. Do you see how often it's supposed to be fetched? At the bottom it shows how often it is actually fetched, as well.
Photo of ecognito

ecognito

  • 21 Posts
  • 5 Reply Likes
According to the statistics, it did have some timeouts (505) previously, but the last three feed fetches have been okay (200). However I am still not seeing new articles in NewsBlur even though I can see them in the raw feed and in Google Reader.

I checked the feed with a validator[1] and there was one minor warning regarding relative URLs, but otherwise it was clean.

[1] http://feedvalidator.org/check.cgi?ur...
Photo of ecognito

ecognito

  • 21 Posts
  • 5 Reply Likes
I've been monitoring this, and there does seem to be timeouts, even when I insta-fetch. Not all the time though. It seems to load fairly speedily for me when I try the feed URL in the browser (even at a time when insta-fetch fails).

And being reddit, it would be unusual I would have thought.

Could there be some connectivity issues between NewsBlur and Reddit servers?

What is the time-out? Perhaps a tad to short?

Thanks.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
So when there's no timeouts it works fine?
Photo of ecognito

ecognito

  • 21 Posts
  • 5 Reply Likes
To be honest, I'm not sure.

I've done insta-fetches that apparently worked successfully, but did not see new articles even though I could see them in the raw feed data. But I do seem to remember seeing new articles earlier on when I was doing this (couple of weeks ago), just not recently.

E.