Sharing layout broken in landscape mode on iPad

  • 2
  • Problem
  • Updated 5 years ago
When using NewsBlur (4.6.1, but also some earlier version from the last few months) on the iPad in landscape mode, pressing the Share button results in a corrupted layout.  Basically it looks like the share page is laid out incorrectly, perhaps trying to lay itself out as though it's in portrait mode?

In any case, rotating the iPad into portrait mode from that point still results in a  corrupted layout, but tapping a few stories down and then back to the original story fixes the layout.
Photo of jangellx

jangellx

  • 7 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Can you post a screenshot? I'd love to know what this looks like. Also, are you in iOS 7 or 8?
Photo of jangellx

jangellx

  • 7 Posts
  • 0 Reply Likes
iOS 8.1.2 on an iPad Air 2.  Here are three screenshots.
- "Before" picture showing the story before I hit the Share button
- "After" picture where I've tapped the button.  Notice the contents seem to be gone, with the list of stories drawing under the translucent box
- Same, but with the keyboard collapsed.

Before:


After:


Collapsed Keyboard:


There are no problems in portrait mode.

Thanks!

-- Joe
Photo of Ken

Ken

  • 90 Posts
  • 12 Reply Likes
https://getsatisfaction.com/newsblur/topics/ipad-app-behaves-all-weird

This behavior is similar to what I see on iOS 7+, except in that case the right pane does not seem to slide under the left, but the left pane items escape their column and slide over the right pane.  The column line between the panes is still visible in that case, but the items from the left pane just don't obey it any more. 

If I had to guess, I would guess it's the same underlying problem that manifests itself differently between iOS 7 and 8.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Oh man, this was one of those bugs. Could not believe it's been around so long! This was the cause of a typo, `width` was supposed to be `height` on a measurement, but I spent two hours on it last night and got nowhere. Then came in this morning and had it licked in 5 minutes. Look for it soon.

Thanks for reporting it so thoroughly! Was a huge help.
(Edited)