Significant Delay for updates or no updates for some feeds

  • 21
  • Problem
  • Updated 6 years ago
Yesterday someone answered a question I asked about feeds being real time under normal circumstances. I am sympathetic to the current challenge supporting an mass influx of users. The answer was that most of the performance problems have been resolved as of Sunday PM and that all feeds are updated in real time.

I created my account yesterday and have yet to see 75% of new articles appear in NewsBlur unless I manually update each feed. I currently have 59 sites. I am not seeing updates for nearly all of the less popular feeds. Some of the more popular feeds are updating very slow - many hours behind.

Are things operating normally overall or do I have a problem with my specific account?

Thanks
Photo of rfc1918

rfc1918

  • 8 Posts
  • 1 Reply Like

Posted 7 years ago

  • 21
Photo of DavidSev

DavidSev

  • 106 Posts
  • 30 Reply Likes
In the case of that feed, the items are missing GUID's so NewsBlur is having to (I assume) fallback to the link, which is the same for every item.

So the feed is broken, it's not publishing new articles it's constantly updating a single article.
Photo of Tim Lavoie

Tim Lavoie

  • 4 Posts
  • 0 Reply Likes
Ah, interesting. I've mentioned to the site, linked to this page as well so they can see what's up. Thanks!
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Stellar detective work, David. As you can imagine, it's rarely NewsBlur's fault when something like this happens. And I don't have the time to investigate every single broken feed, especially considering it's the publisher's fault.
Photo of Paweł Bo

Paweł Bo

  • 3 Posts
  • 0 Reply Likes
I fight with the RSS feed here for some time
http://wyborcza.biz/pub/rss/wyborcza_...
RSS is a regularly updated, but in my account no new messages
I tried deleting and adding the feed but it does not change anything,
newblur in the settings page shows me the page is updated