Text parsing doesn't work on nytimes.com

  • 2
  • Problem
  • Updated 3 months ago
Both of the NYT feeds I subscribe to have problems when I switch to text view -- most of the time the text view parser doesn't include the first several paragraphs of the article and often trims off the end as well.  Not sure why.  This is a long term issue but I haven't raised it until now.

http://rss.nytimes.com/services/xml/rss/nyt/HomePage.xml
http://rss.nytimes.com/services/xml/rss/nyt/Politics.xml

Affected feeds.
Photo of Ryan B

Ryan B

  • 3 Posts
  • 0 Reply Likes

Posted 4 months ago

  • 2
Photo of Stuart Falk

Stuart Falk

  • 45 Posts
  • 1 Reply Like
I have previously reported that the NYT feed does not work in full view where it only shows a blank page. I've had to switch to split view, which requires one to click on each unread story. This only happened following the recent site update and has not been corrected. I have no such issue with any of my other feeds, so something strange is going on with the NYT feed that needs exploring. 
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6244 Posts
  • 1416 Reply Likes
Photo of Ryan B

Ryan B

  • 3 Posts
  • 0 Reply Likes
Hi Sam,
The issue is that it doesn't work consistently.  Sometimes the Text view shows all the correct article text; most of the time it doesn't.  Two screenshots attached from the first article in the feed at the moment:  http://www.nytimes.com/2016/12/22/briefing/europe-briefing.html?partner=rss&emc=rss.

See how the nytimes.com page has five paragraphs of text at the top that the Text view doesn't grab?  This is the typical behavior that is problematic.  It is not always five paragraphs -- could be more, could be less.

Thanks, Ryan



Photo of Douglas Lee

Douglas Lee

  • 4 Posts
  • 0 Reply Likes
Same here - it's been a long term issue for me as well.
Photo of Douglas Lee

Douglas Lee

  • 4 Posts
  • 0 Reply Likes
Additionally, on many NYT stories, text following a break or photo often come through in italics, like so: