Unread stories don't load. Only read stories load.

  • 5
  • Problem
  • Updated 2 years ago
When I click or use the arrows to move to an Unread story, the story is marked as read but nothing appears in the story pane.  If I click on a different story, then click on the original now-read story, the story appears.  The Chrome Developer Console shows this exception:

Uncaught TypeError: d.is_social is not a function    at d.update_read_count (common.js?1490313325:1618)
    at d.<anonymous> (common.js?1490313325:1616)
    at d.mark_story_hash_as_read (common.js?1490313325:1489)
    at d.<anonymous> (common.js?1490313325:1616)
    at d.mark_read (common.js?1490313325:1616)
    at detect_selected_story (common.js?1490313325:1624)
    at d.select_story (common.js?1490313325:1607)
    at u (common.js?1490313325:1014)
    at d.trigger (common.js?1490313325:1012)
    at d.set (common.js?1490313325:1017)
Photo of Hand-E-Food

Hand-E-Food

  • 9 Posts
  • 1 Reply Like
  • frustrated

Posted 2 years ago

  • 5
Photo of J. Quintanilla

J. Quintanilla

  • 50 Posts
  • 5 Reply Likes
I'm having this problem too.
Photo of Hristo Hristov

Hristo Hristov

  • 12 Posts
  • 0 Reply Likes
If you navigate with "j" on the keyboard, the view is not scrolling for unread stories, but they are marked as read. If you navigate back with "k", the view is scrolling.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Yes, this is possible. I just pushed out a big update that I'll announce on Monday. But I need to make sure everything's working. 

Can you post a screenshot? I'm having trouble reproducing the bug. I really just need to know which view settings you have setup for the feed or folder.
Photo of Hristo Hristov

Hristo Hristov

  • 12 Posts
  • 0 Reply Likes
Here the "focus" should be on the "Docker Blog" story, as I have just pressed "j", but it's not. If I continue pressing "j", it would mark stories as read, but will not scroll to them.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
You're probably reading a folder in the List view and using the Feed view. I just pushed out a fix for the issue you're describing. Let me know if that works out, just reload the page.
Photo of Hristo Hristov

Hristo Hristov

  • 12 Posts
  • 0 Reply Likes
Yes, the fix works for me, thanks!
Photo of Hand-E-Food

Hand-E-Food

  • 9 Posts
  • 1 Reply Like
While my problem didn't exactly resemble Hristo's, I can't replicate my problem any more.

Thanks Samuel!  :-)
Photo of Robert

Robert

  • 20 Posts
  • 10 Reply Likes
I am also no longer experiencing this problem, thank you!