Unread counts are sometimes incorrect. Or, counting really is hard.

  • 2
  • Problem
  • Updated 8 years ago
I have noticed this several times since starting to use NewsBlur this past weekend.

In the screenshot below you can see 2 problems.

1) The "News" folder shows 2 unread, however only 1 feed is visible with 1 unread item.

2) The 1 unread item that it says Ars Technica doesn't exist. i.e. There are no unread items in the Ars Technica feed that I can find. When I closed NewsBlur and re-opened it however, the Ars Technica feed refreshed and a new unread post was shown at the top of the feed list. So, the problem appears to be that the sidebar refreshed and learned about this new feed item while the feed view I was on remained ignorant until I reloaded the whole page. Kind of frustrating.

Photo of Joshua Poehls

Joshua Poehls

  • 75 Posts
  • 13 Reply Likes
  • confident

Posted 8 years ago

  • 2
Photo of Joshua Poehls

Joshua Poehls

  • 75 Posts
  • 13 Reply Likes
I just had this issue on my Hacker News feed but it was slightly different.

1) I loaded NewsBlur and Hacker News showed 3 unread items
2) I clicked on Hacker News and read the 3 items (they unbolded in the story pane)
3) Hacker News still shows 1 unread item. But nothing is bold in the story pane. Hitting the 'n' shortcut key or clicking the buttom to go to the next unread item doesn't do anything. Completely refreshing the page doesn't change anything either. Still 1 unread item but I can't find it.

... and while typing this I decided to refresh again and of course I clicked Hacker News and found the 1 unread item in the story pane. It really is out of sync with the sidebar.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
I'm working on making this real-time, so it's less of an issue. The problem is in how those unread counts update. There is a 60 second lag-time, and if a new story shows up in those 60 seconds, the unread counts will be wrong.

The solution is actually built and ready to go, but it's so brand spanking new that it's a bit risky, so I'm testing it out on my own right now. And I'm taking the week off for Thanksgiving to head to NYC to visit friends, so it may be a few weeks before I launch real-time updates widely.

When I do, I'll blog about it, since I'm using a bunch of technologies that are all younger than NewsBlur itself (Redis, Socket.io, Node.js, CoffeeScript, etc, etc).
Photo of Joshua Poehls

Joshua Poehls

  • 75 Posts
  • 13 Reply Likes
That sounds great. Thanks for the update! This is definitely a minor annoyance but it is good to hear you have it under control. I can't wait for the blog post for more of the tech details.
Photo of Daniel Woolstencroft

Daniel Woolstencroft

  • 12 Posts
  • 1 Reply Like
Do you have any mechanism in place to allow users to beta test features? Even if it's on a separate server (physical or virtual). I'm sure some of us would have no objections to trying things out for you if that would help.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
I do have a staging server, but I only turn it on when I have a very big feature to test and it needs to interact with real data (and not just the feeds I have on my local development environment).

For the most part, newsblur.com is running the latest code. I have a few branches going, but as soon as they are done being developed, they get merged back into the master branch and deployed. It's just not safe or a smart idea to develop web software with a lot of lead-time between developing and deploying. Stuff gets forgotten, bugs aren't immediately realized, etc, etc. I'd rather build fast and break things than to get it absolutely right the first time after a long incubation and development period.

You'll notice this when I deploy the realtime branch sometime soon (this week?). I may have a staging server setup to test it, but it'll probably just go right out.
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
OK, just deployed what I hope is a fix for this. Please, please, please let me know if it shows up again. The fix was rather trivial and it didn't address the issue head-on, but it is very possible that this will solve the issue.