Video not working in Chrome

  • 4
  • Problem
  • Updated 6 years ago
The video embeds won't work in Chrome. Newsblur only displays a blank area where the video should be. The problem only appears in Chrome, in Safari everything is fine. Can you tell me what's going on?

Flash is up-to-date.
Photo of Daniel Joudrey

Daniel Joudrey

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 4
Photo of Sean Murphy

Sean Murphy

  • 31 Posts
  • 11 Reply Likes
Google recently changed Chrome to block mixed content by default. The main newsblur UI is sent over HTTPS, but streamed video is sent over plain HTTP, so it gets blocked.

If you click the shield icon on the right side of the address bar, you can allow the insecure content, but you will have to re-allow it each time you reload newsblur.

You'll have the same problem in Firefox, but the shield icon will be on the left.
Photo of Chris

Chris

  • 1 Post
  • 0 Reply Likes
You can add --allow-running-insecure-content to the shortcut of chrome to play those videos over http while in a https session, however this is chrome wide and can be a security risk, be advised before you use that setting.
Photo of satmandu

satmandu

  • 27 Posts
  • 1 Reply Like
The big problem with clicking on the shield is that while enabling the content, it also reloads the page, while the story with the video you wanted to see is now marked as read, so it doesn't show up on the reload.

Perhaps one solution would be to have a small video element on the main newsblur pane, such that you can click on the shield to enable insecure content for everything on newsblur, before you start browsing stories.

Is that less of a hack than enabling insecure content with a startup flag that makes ALL sites insecure?
Photo of Carlos De Sedas

Carlos De Sedas

  • 2 Posts
  • 0 Reply Likes
Hi.. So any solutions from Newsblur on this? I might switch to Feedly if this is not fixed. Bummer, I love Newsblur!!
Photo of Edu Eduardo

Edu Eduardo

  • 18 Posts
  • 0 Reply Likes
No problem here.
Photo of satmandu

satmandu

  • 27 Posts
  • 1 Reply Like
It's a mixed content issue. Switch to http in your newsblur settings and the problem goes away. Maybe using the https everywhere extension might fix this. Maybe.