Videos won't work in Firefox

  • 3
  • Problem
  • Updated 6 years ago
The video embeds won't work in Firefox (i'm using the Aurora branch) for some weeks. Newsblur only displays a blank area where the video should be. The problem only appears in Firefox, in Chrome everything's fine. Could you look into it? You can use Boing boing as a test feed.

Photo of Szedlák Ádám Zoltán

Szedlák Ádám Zoltán

  • 2 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 3
Photo of Samuel Clay

Samuel Clay, Official Rep

  • 6514 Posts
  • 1474 Reply Likes
Did you disable flash? That's probably the culprit.
Photo of Szedlák Ádám Zoltán

Szedlák Ádám Zoltán

  • 2 Posts
  • 0 Reply Likes
No, Flash works all right in other tabs. To make it more mystical, Soundcloud embeds do work, only the content of video iframes are missing.
Photo of LaSombra

LaSombra

  • 9 Posts
  • 2 Reply Likes
I'm having this issue with Chrome and Firefox :(
Photo of Alejandro Yee

Alejandro Yee

  • 7 Posts
  • 0 Reply Likes
No problem so far to me.
Photo of LaSombra

LaSombra

  • 9 Posts
  • 2 Reply Likes
Weird. I see this on both Mac OS and Linux and on Chrome and Firefox. If I open the sites it works fine, but inside NewsBlur it doesn't work.

Any ideas how to try and debug this?
Photo of Alejandro Yee

Alejandro Yee

  • 7 Posts
  • 0 Reply Likes
Maybe it has to do with some websites specifically.
Photo of LaSombra

LaSombra

  • 9 Posts
  • 2 Reply Likes
Failblog amongst others. Interesting enough it's working on Safari and Opera.
Photo of LaSombra

LaSombra

  • 9 Posts
  • 2 Reply Likes
Problem solved. Mixed content from https and http.

I used NewsBlur on HTTPS only and websites with Flash were all HTTP, so mixed content didn't show up. I think this was changed recently on Chrome, around version 28 or so.

On Firefox you want to manually disable this setting for NewsBlur.
Photo of Antonis Lamnatos

Antonis Lamnatos

  • 37 Posts
  • 2 Reply Likes
Same here, no flash videos on Firefox.

How come mixed content works with Chrome but not with Firefox?
Photo of LaSombra

LaSombra

  • 9 Posts
  • 2 Reply Likes
On Chrome you have to change NewsBlur to use a standard connection (non secure). On Firefox you can click on the shield left to the address bar and click on "Keep Blocking", it'll show you an option to allow mixed content from newsblur.com