I’m frustrated

2 Major Problems on Numark Mixdeck.

FIRST BIG PROBLEM: BPM Counter bug
The first problem I faced with Numark Mixdeck was the BPM Bug / Glitch / Whatever it is.
First of all I have to say is that the firmware is updated to v042 (the last one)
You can clearly see this problem on several Youtube videos like this one and this one and this even happens on the Mixdeck and NDX 900 (to my knowledge), not only mixdeck...
The BPM Counter just shows up a wrong BPM when I load a track on whatever deck and even if I load the same track on each deck it shows a DIFFERENT BPM on each one and it seems to recalculate the bpm on a time interval because the bpm changes every time I watch the bpm count (even if I didn't ordered the deck to recalculate it).
For some songs it does a good job but for the majority it just doens't work... If I load a 140 - 150 BPM (it happens with every bpm, not only 140-150)songs it can say it's 123,6BPM or 130,7 BPM for example, it's a random number, not even close to the real BPM and its DECIMAL.
If you want to use the TAP button to tell the deck, "ok man I'm going to help you", you can't even help it because all the numbers are decimal, if I want to tell the deck it's 150 BPM, I have to tap 200 times to get a 150,4BPM because my hand is not a robot that press the button inmediatly.
I know I sound a little pissed off but I'm not. I'm trying to explain the best I can to help me and a LOT of other people to solve this problems because it seems like a common problem (My Mixdeck does NOT need a service manteinance, thanks).
My flash drives are exactly formatted like the manual says and all the files are MP3 320kbps, no problem there.
Maybe a firmware update can solve it? I can send a MP3 file to you if you need to test it before doing a fix to the firmware :).
------------------------------------------------------------------------------------------------------
SECOND COLOSSAL PROBLEM: Windows 10 Compatibility
You can use the mixdeck like a MIDI controller (just like it's a mixtrack(not even pro)) if you disable the SoundCard of the mixdeck and just open virtualdj or serato or whatever but when I try to make the "numark mixdeck audio" device sound (going to control panel, sounds, select the numark mixdeck and press "test) , it just freeze like 10 seconds with the volume up (not sounding at all, it just shows the freezed volume like this:), and then the USB disconnect itself and goes on again but this time I get an "unrecognized usb" error like this

It does the same if I open the "Mixdeck Panel" Software. It just shows the window, says the mixdeck is connected, then windows says the software is not responding and about 5 seconds later the USB goes off, goes on and unrecognized.
I have a laptop with Windows 7 32 bits installed so I installed the driver on it and it works flawlessly, no lag, no unrecognised, nothing wrong, so I installed Windows 7 64 bits on it, and it also worked fine...
Then I installed Windows 10 32 bits on it, and it does the same thing on windows 10 64 bits and 32 bits, so the problem is windows 10 related, not 64 or 32 bits because I installed the latest driver on every machine and windows and it worked fine on windows 7.
I have Intel i5 processor on each machine but I don't think it matters... it's windows 10 related.. It's the latest windows 10 on both cases, maybe it's problem of the new "spacial sound" or sound enhacements of wnidows 10 or something like that

VERY IMPORTANT NOTE: While I was writing this, I'd installed the latest driver again and choose not to restart the computer (everytime I installed the driver before I restarted the pc just after the installation) and the soundcard now DOES work but I'm afraid that if I restart the PC, it won't work again... (also just work the Audio Device, not the MIDI, VDJ and Serato doesn't move at all, and the output is also pitched down, it's not correct.)
Is there a service or something that windows does block after the restart?
SIDENOTE: Yes, it doesn't work if you restart the PC... So PLEASE, if you try something,try it in the last windows 10 version, maybe they added something that blocks mixdeck audio device or something.

I hope someone take the time to analize this case because those are common problems on this product. Thanks in advance and I hope and pray for an answer.
5 people have
this problem
+1
Reply