I’m frustrated

no sound with TTUSB

I have been using my system with no problem and now I can't get any sound nothing has changed on my end. I can't even get sound thru speakers
1 person has
this problem
+1
This topic is no longer open for comments or replies.
  • Hello,

    Thanks for the post. I'd like to help! Are you connecting this turntable to your computer via USB or through a receiver? If a home receiver, please ensure that you're connecting this to the RCA Line Input instead of the Phono Input. If you're using a computer, ensure that the only USB device that is connected to your computer is your turntable. Then setup your computer with the following:

    Make sure you have the latest version of the EZ Converter software installed - https://www.ionaudio.com/ezvc/.

    Windows Vista, Windows 7 and Windows 8 Sound Settings

    Playback Settings

    1. Click the Start button.
    2. Select Control Panel.
    3. Double Click Hardware and Sound it may only say Sound.
    4. Double Click Sound, the Sound Settings window will open.
    5. Under the Playback Tab click on your computers sound card and speakers.
    It may say one of the following (Realtek, SoundMax, Sigmatel, Sound Blaster, Conexant, IDT)
    6. Click Set Default at the bottom of the window.

    Important: Make sure the USB Audio Codec/USB PnP Audio Device is NOT your Default playback device.

    Recording Settings

    1. Click on the Recording Tab.
    2. Click on Microphone USB (Codec, PnP, Array).
    3. Click Set Default.
    4. Click Properties on the bottom of that window - Microphone Properties window will open.
    5. Click on the Levels Tab.
    6. Set the level to 5 (Windows 7) or 25 (Vista).
    7. Click on the Advanced Tab.
    8. Set the Sample Rate to 2 Channel, 16 bit, 44100 Hz or 44800 Hz.
    9. Uncheck both Exclusive Mode boxes.
    10. Click Apply, then OK to exit.

    * In some cases a restart is required to the level to save at 5 or 25 depending on your Windows version.
    * The microphone is very sensitive and needs be set this low to avoid distortion.

    Windows XP Sound Settings

    1. Click Start button.
    2. Select Settings, then Control Panel.
    3. Click Sounds, Speech, and Audio Devices.
    4. Choose Sounds, and Audio Devices. This will open the Sounds and Audio Devices Properties.
    5. Click on the Audio Tab.
    6. Under Sound Playback Default Device choose your sound card. (Realtek, SoundMax, Sigmatel, Sound Blaster, Conexant)
    7. Under Sound Recording Default Device choose the USB. (USB Audio Codec, Pnp Audio Device, Microphone Array)
    8. Under MIDI Music Playback Default Device no changes necessary.
    9. Click on the Voice Tab and mirror these settings.
    10. Click Apply to save, then click OK to exit.

    Mac OS X Sound Settings

    1. Click the Apple icon in the top left corner
    2. Select System Preferences...
    3. In the window that opens, under Hardware, click Sound.
    4. At the top of the new window that opens click on the Output tab.
    5. Click on Internal Speakers or Headphones to set this as the default.
    6. Click on the Input tab.
    7. Click on the USB Audio Codec/PnP Audio Device to set the default (Adjust the Volume to desired level).

    *If Line in or Internal Microphone is selected as your default you may hear your voice during recording.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly sad, anxious, confused, frustrated indifferent, undecided, unconcerned happy, confident, thankful, excited