NS7II Controller Issues

I recently started using my NS7ii again after about a year, and at first my serato dj software couldn't recognize my controller so I update the serato version and also updated my NS7ii drivers and firmware to latest version and everything seemed to work fine again except for some issues. 

The right side of the controller works fine. However the left side is screwed up. 

1. When I populate a song into 1 or 3 and press play the song won't start. Whats really messed up is that 1 is populated with a song and 3 isn't, if I sometimes press 3 the song will start. Same goes for if I populate 3 with a song and 1 is empty if I press 1 the song on 3 starts.... soo wtf. 

2. On the left side if say a song is playing on 3 if I just move the turntable a little bit the song just stops playing. Same goes for if a song playing on 1. 

3. The left turntable does not turn by itself. I thought maybe it was the shift+motor button was on but it wasen't, so thats concerning too. 

Hope someone can help me with this, cause at this moment my NS7ii is unusable. 

Thanks.
1 person has
this problem
+1
Reply
  • Hi Donny,

    Thanks for posting. Sorry you're having issues with your NS7II. 

    Can you please provide me with your full system specs, as well as the version of Serato DJ you're using? 
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • Hello,

    My system specs:

    - Macbook Pro - MacOS High Sierra
    - Processor 2.6 GHz Intel Core i5
    - 8 GB 1600 MHz DDR3

    - Serato Dj Pro Version 2.0.2

    From Numark website under NS7II I downloaded;
    - NS7II Firmware Update v1.05 (Mac)
    - Mac OSX 10.12 Driver v3.3.17

    Also I been messing around with the left side again and this if an update of what I found.

    - If I populate a song into 1 or 3 with the turntable motor set to on with the Shift+motor button on, even though it still does not spin and press play the song will work. I can even move the left turntable by hand and the song will not drop.

    However if the turntable motor is set to off, and I move the turntable by hand, the song stops. If I press play after the song stops, it will not start. Then I find the song will just randomly start again by pressing 1 or 3 alternatly until it starts again.

    Also the left turntable won't automatically spin no matter what.
    I coulda sworn that when I first turned on the unit a few days ago after a while that the left did move briefly then I heard a little ping sound then it stoped, unless I was hearing things.

    Thanks
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • Alright, based on the symptoms you've described, this sounds like it could potentially be a hardware-related issue. Please get in touch with your nearest Support Office for assistance with this over the phone. You can find their contact information on that page.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. happy, confident, thankful, excited kidding, amused, unsure, silly indifferent, undecided, unconcerned sad, anxious, confused, frustrated