I’m frustrated

NS7II locking up/looses MIDI control

The controller will suddenly cease to be responsive after unspecified period of time. In order for me to correct the issue I would have to restart the controller or remove the usb cable and re-insert it. The issues seem to happen more after upgrading to windows 10 from 7. I did a clean 10 install, but it still would happen. I removed and re-installed drivers, firmware, turned off windows services. I tried the controller with virtual dj as a test and it still happened. I have a NV controller which works fine. The locking up issue also would happen when I went from a full screen setting to a windowed screen in Serato. I adjusted audio settings, but that didn't help at all. The last thing I did was try disabling the platters. Interestingly, when I did that the controller worked fine. I loaded all 4 channels with music, I went in an out between the windowed and full screens, and everything was great. I kept loading music for about 30 minutes and everything was good. The minute enable the platters and did the full screen to windowed screen it locked up. The issue seems to be with the platters. Sometimes when it locks up the tempo will suddenly speed up. The only control I have with the controller is the master control knob. This who thing is really frustrating. As a note, several times I would get a Windows message that said "Windows has detected that audio enhancements for the following device are causing problems" and it would mention the NS7 audio device.
1 person has
this problem
+1
Reply