I accidently destroyed my NS7ii when the power to my computer disappeared. I thought it was problem with my firmwire because it was no connection between my computer and NS7ii just the analog mixer was working. I tried to update the firewire but it did’nt work, then I did a stupid thing I tried to update the firewire by hold LOAD A, LOAD B and FWD and that did'nt work at all. Now is no signal at all... it’s possibly that I can reboot the whole controller ore is my controller total broken?
1 person has
this problem
  • Hi Erik,

    Sorry you're having issues with your NS7II.

    It sounds like your product may need to be serviced. Warranty and non-warranty claims are not handled here on the forum, but I can point you in the right direction! Here are a couple of options that you could choose from:

    • Submit a Warranty or Service inquiry with our Technical Support team by logging onto the Numark Support Page. Select Warranty or Service Inquiry from the drop down menu.


    • For quicker support, call your nearest Support Office or International Distributor.

    Make sure to reference or link this thread to help out the support team.

    I hope this helps! Let me know if you have any additional questions.
  • (some HTML allowed)
    How does this make you feel?
    Add Image

    e.g. sad, anxious, confused, frustrated kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited