I’m really frustrated

Traktor not recognizing Mixtrack Pro

Hi,
I'm having a problem with a Traktor 2.
The problem in essence in fairly simple and I hope to get a viable solution, or at least an explanation. It arises when I try to connect the Numark MixtrackPro to my Mac. Traktor simply does not recognize the controller as an audio device. I have tried running the wizard multiple times, I have tried turning it off and on again, I have tried checking does the Mac recognize it, which it does, both as a MIDI controller and as an audio device. Same works for Logic. Same works for Serato. In Traktor though, when ran through the wizard, under audio devices it is stated as "MixtrackPro (not connected)", and suggests to check my outputs, otherwise, it isn't even listed as the option.
Is there some sort of a catch, as in can't use Traktor with High Sierra, or the latest version of Traktor does not support MixtrackPro, or I missed the crucial step, or there is an extra step due to new updates, or... literally anything to help?
I have tried erasing the icon in the MIDI Studio and rebooting.
Thank you for your time and help.

Best regards
1 person has
this problem
+1
Reply
  • Hello,

    Thanks for posting. 

    Make sure your controller is connected to your computer prior to launching the software and that you're using the latest version of Traktor. After you've done this, follow these steps below to configure your controller within Traktor:

    Configuring the Controller Settings

    1) In Traktor, go to Help > Start Setup Wizard. 
    2) In the window that opens, click Next. 
    3) Next, you’ll be asked, Are you using a USB/FireWire controller? Choose Yes, then click Next.
    4) On the next page, next to Chose your manufacturer, choose Numark. 
    The selection you make next to Choose your model will depend on which version of Traktor you're using. Note that making the incorrect selection in this step will prevent your controller from properly controlling the software. If you're using Traktor Pro, you should choose Mixtrack here. 
    5) Click Next, then click Finish on the last page to close the Setup Wizard Window. 

    Configure the Audio Device Settings
    
    1) Open the Preferences menu in Traktor by clicking the gear button in the upper-right corner of the screen. 
    2) In the upper-left of the window that appears, select Audio Setup. 
    3) Select the Mixtrack Pro as the Audio Device. 
    4) Next, on the right-hand side of the window, select Output Routing. The Mixtrack pro has two sets of stereo outputs. Your audio settings should be configured as followed:

    • Set Mixing Mode to Internal.
    • Set Output Monitor to 
      L             3: Back Left
      R            4: Back Right
    • Set Output Master to
      L             1: Front Left
      R            2: Front Right
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Thank you for your answer, however, I believe you haven't read the question properly, as it is stated that I have tried that process multiple times with no result whatsoever. Multiple times with multiple models of mixtrack selected as controller.
    It does not recognize mixtrack as an audio device no matter what I do. Got any out of the box soultions?
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated

  • Alright, if you're still having issues, this may be an issue with the mapping file that you're using with Traktor. That being said, I would recommend getting in touch with Native Instruments directly - https://www.native-instruments.com/en/
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly indifferent, undecided, unconcerned happy, confident, thankful, excited sad, anxious, confused, frustrated