Annoying "Thanks" page after every reboot

  • Problem
  • Updated 3 years ago
I installed your Google Maps extension for Safari (OS X) and I am greeted with your "hello,,,,thanks for installing...." page EVERY time after a reboot. How do I make it stop?
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
  • frustrated

Posted 5 years ago

  • 1
Photo of Jay

Jay, Product Manager

  • 139 Posts
  • 7 Likes
Sorry about the inconvenience. This is the first time I hear such problem. Have you made any special configuration for your Safari? Such as reset Safari or empty cache on re-boot.
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
Ah, well, yes....I'm always emptying the cache.
Photo of Jay

Jay, Product Manager

  • 139 Posts
  • 7 Likes
Once you keep its version number, the extension knows you have seen the thankyou page and will not annoy you again.
Photo of Jay

Jay, Product Manager

  • 139 Posts
  • 7 Likes
The extension checks whether its version number is available on its launch. If not, it assumes it is a new installation, opens the thankyou page and saves the version number.

Please try this: Reboot Safari without clearing the cache and see whether the thankyou page shows up again.

Thanks.
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
I rebooted without emptying cache. Thank You page didn't load. So, what does this mean?
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
Thanks Jay. That fixed it.
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
Noooooooooo......that didn't fix it! It's baaaaaaaack! It seems that if caches are cleaned with Cocktail or Cache Out X the page returns, rising like a zombie from the dead, to inhabit the night - and my browser.

Does this mean if I don't want to see that page again, I can never empty Safari's cache?!? Oy! Make it stop....
Photo of Jay

Jay, Product Manager

  • 139 Posts
  • 7 Likes
The extension uses localStorage, a special way to store information, to save the version number. It is different from cache and is NOT cleared by Safari through the default way. I guess the problem results from Cocktail and Cache Out X. These softwares change the default setting of Safari and remove everything.
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
Jay-

Looks like this will be fixed by developer of Cocktail in next update after I wrote them:

From: Maintain
Date: August 25, 2010 9:22:39 AM CDT
To: Jim Passin
Subject: Re: Proust would chuckle....

Hello,

Thank you very much for your email. We will fix this issue in the next update.

Regards,

Kristofer Szymanski
Maintain

Email: cocktail@maintain.se
Home Page: http://www.maintain.se
Address: Ekuddsvagen 20 B, 178 34 Ekero, Sweden

On 22 aug 2010, at 20.07, Jim Passin wrote:

Well, here's the problem: I've installed Turn Off The Lights and Google Maps extensions for Safari. After running Cocktail, BOTH of these extensions open their "Hello/Welcome" pages when Safari is launched after reboot. You see, they keep their "been there....done that" files in the ~/Library/Safari/Local Storage/ folder. As it turns out Cocktail sniffs out, attacks, eats, swallows and licks clean this hapless little folder, along with the extensions' historical contents, every time so that these apps have no record of having displayed those now-irritating pages. They think it's their first rodeo - every time!

So, if there is no way of making Cocktail stop its Hunnish ways when it comes to this particular folder, could you maybe think about addressing this little issue in a future update? Huh? Could ya please, maybe? I'm getting really tired of seeing those pages every day!

Well, keep up the good work and...

All Power To The Peephole,

Jim
Photo of Jay

Jay, Product Manager

  • 139 Posts
  • 7 Likes
Awesome. I love your letter to them. LOL
Photo of byrnejohn77B

byrnejohn77

  • 1 Post
  • 0 Likes
Jay,

I have the same problem. MY question is how this add on got installed in the first place and how do I remove it in Safari? I didn't specifically request this be installed by selecting it from a list of add-ons or something and I'm frankly offended that Google took it upon themselves, apparently, to install this without my consent in the first place.

How do I get rid of it altogether in Safari 5.0.2 on the Mac? I'll use maps.google.com if I want directions somewhere. And why is it MY responsibility to notify vendors to correct this? I use NetShred and apparently it does the same thing.

John
Photo of Jim Passin

Jim Passin

  • 9 Posts
  • 1 Like
There, there, byrnejohn. You, or somebody using Sari on your machine, must have gone to the Extensions Gallery at some point and clicked on the "Install Extension" button....maybe even accidentally. That's the ONLY way an extension can be added to Safari. No matter -- not to worry. Just follow Jay's instructions and click the uninstall button in the Extensions pane in Safari preferences and pooooof it'll be gone.

And as to users notifying 'vendors': well, different problems sometimes show up in different ways on different systems. And when many users notify a 'vendor' better results will be obtained rather than if one developer notifies a 'vendor' of a problem.
Photo of Jay

Jay, Product Manager

  • 139 Posts
  • 7 Likes
Safari extension Mini Google Maps is featured in the official Safari extension gallery. You may get it from there .

The reason for your problem is similar to Jim. I suggest you notify the developer of NetShred.

To uninstall a Safari extension: go to Safari - Preference - Extensions, then select the extension you want to remove.
Photo of Brian ChambersBC

Brian Chambers

  • 1 Post
  • 0 Likes
"To uninstall a Safari extension: go to Safari - Preference - Extensions, then select the extension you want to remove."

When I follow the above instruction to remove Mini Google Maps, I can find the relevant page (under search tools) and the extension label reads "installed". However, there appears to be no way (by clicking, etc.) that I can "select" this extension to remove it.

Help! please.