I’m anxious

rc4 encryption

Hello,

I tried to log into OpenClass using Chrome (version 48.0.2564.82 m), and got the following error message:

"This webpage is not available

ERR_SSL_VERSION_OR_CIPHER_MISMATCH
Hide details
A secure connection cannot be established because this site uses an unsupported protocol or cipher suite. This is likely to be caused when the server needs RC4, which is no longer considered secure."

This is likely due to Chrome updated it's browser and disable support for RC4, and further reading means that Edge, IE and Firefox will be dropping RC4 support in the near future.

(Source 1: http://venturebeat.com/2016/01/20/chr...)

(Source 2: http://venturebeat.com/2015/09/01/goo...)

My question: What actions will Pearson be taking to resolve this issue? Or, what suggestions would that they make to the end user moving forward?

Thanks,
5 people have
this problem
+1
Reply