(Please Help) All Downloads stuck on starting up

  • Question
  • Updated 2 years ago
I downloaded Miro yesterdayand I can't seem to get my videos to download. When I click on a video to download says it is starting up and it doesn't download. My firewall is not blocking Miro
Photo of JimJ

Jim

  • 1 Post
  • 0 Likes
  • confused, and Fruustrated

Posted 6 years ago

  • 39
Photo of JED

JED, Official Rep

  • 870 Posts
  • 97 Likes
it would be helpful if you could provide your os, an example url and log file (Help Diagnostics) information.
Photo of ErwinE

Erwin

  • 2 Posts
  • 1 Like
Same problem here:
- OS X (10.5.7).

For what it's worth, it shouldn't be a disk space problem: There's 5GB free and Miro is configured to leave 0.2GB free or so.

When I cancel the stalled downloads the same stalling happens with the next set of downloads.

Grabbed from /var/log/syslog (while replacing "mythical [0x0-0x25b25b].org.participatoryculture.Miro[6812]" with "[...]" to improve readability a bit):

Jul 24 08:41:51 [...]: WARNING Unhandled exception: OC_PythonException
Jul 24 08:41:51 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/__boot__.py", line 31, in ?
Jul 24 08:41:51 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/__boot__.py", line 28, in _run
Jul 24 08:41:51 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/Miro.py", line 149, in ?
Jul 24 08:41:51 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/Miro.py", line 109, in launchApplication
Jul 24 08:41:51 [...]: File "miro/plat/frontends/widgets/application.pyo", line 76, in run
Jul 24 08:41:51 [...]: File "miro/plat/frontends/widgets/window.pyo", line 74, in sendEvent_
Jul 24 08:41:51 [...]: File "miro/plat/frontends/widgets/application.pyo", line 338, in exceptionHandler_shouldLogException_mask_
Jul 24 08:41:52 [...]: WARNING Unhandled exception: OC_PythonException
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/__boot__.py", line 31, in ?
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/__boot__.py", line 28, in _run
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/Miro.py", line 149, in ?
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/Miro.py", line 109, in launchApplication
Jul 24 08:41:52 [...]: File "miro/plat/frontends/widgets/application.pyo", line 76, in run
Jul 24 08:41:52 [...]: File "miro/plat/frontends/widgets/application.pyo", line 338, in exceptionHandler_shouldLogException_mask_
Jul 24 08:41:52 [...]: Checking Miro preferences and support migration...
Jul 24 08:41:52 [...]: Traceback (most recent call last):
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/__boot__.py", line 31, in ?
Jul 24 08:41:52 [...]:
Jul 24 08:41:52 [...]: _run('Miro.py')
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/__boot__.py", line 28, in _run
Jul 24 08:41:52 [...]:
Jul 24 08:41:52 [...]: execfile(path, globals(), globals())
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/Miro.py", line 149, in ?
Jul 24 08:41:52 [...]:
Jul 24 08:41:52 [...]: launchApplication()
Jul 24 08:41:52 [...]: File "/Users/media/Applications/Miro.app/Contents/Resources/Miro.py", line 109, in launchApplication
Jul 24 08:41:52 [...]:
Jul 24 08:41:52 [...]: OSXApplication().run()
Jul 24 08:41:52 [...]: File "miro/plat/frontends/widgets/application.pyo", line 76, in run
Jul 24 08:41:52 [...]: File "miro/plat/frontends/widgets/window.pyo", line 74, in sendEvent_
Jul 24 08:41:52 [...]: File "miro/plat/frontends/widgets/tableview.pyo", line 553, in rightMouseDown_
Jul 24 08:41:52 [...]: File "miro/plat/frontends/widgets/tableview.pyo", line 560, in handleContextMenu_
Jul 24 08:41:52 [...]: ValueError:
Jul 24 08:41:52 [...]: depythonifying 'unsigned int', got negative 'int'
Jul 24 08:42:07 [...]: WARNING Incorrect preference value -0.0416666666667 for key expireAfterXDays, using failsafe: -1
Jul 24 08:42:07 [...]: Traceback (most recent call last):
Jul 24 08:42:07 [...]: File "logging/handlers.pyo", line 73, in emit
Jul 24 08:42:07 [...]: File "logging/handlers.pyo", line 147, in shouldRollover
Jul 24 08:42:07 [...]: ValueError: I/O operation on closed file
Photo of ErwinE

Erwin

  • 2 Posts
  • 1 Like
I had some pending OS X updates and one (Safari, but I doubt that matters) required a reboot. After the reboot Miro started back up as usual and now the downloads aren't stalling anymore. No idea why that made a difference!
Photo of mrronsealM

mrronseal

  • 6 Posts
  • 1 Like
I've got this issue too, with youtube videos, the "starting up" message stays for what seems like minutes before it actually starts.

I'm using the 2.5 release version on Debian Lenny/Squeeze

Here is a feed that does it.

http://gdata.youtube.com/feeds/base/u...
Photo of JayJ

Jay

  • 1 Post
  • 0 Likes
I have the same issue, tried uninstalling and then re-installed Miro but get the same result. Doesn't matter what I try to download it just gets stuck on starting up. Mac OSX 10.5.8 Running the latest version of Miro.
Photo of MurujM

Muruj

  • 2 Posts
  • 0 Likes
Hello people,

I have the same problem since yesterday; before, all my bittorrent downloads worked fine, now they either don't start up or just stopped respectively. I don't have a firewall, didn't change anything in my system or network connection since yesterday; there's enough seeds and the tracker seems to be online and alive.

I'm running Ubuntu 9.04, Miro 2.0.3. It would be great if anyone could offer some help.

Miro is a great program, thank you for that! I just hope I don't have to change to a different one because it doesn't work anymore.
Photo of JED

JED, Official Rep

  • 870 Posts
  • 97 Likes
could it be a problem with your tracker? Are there any messages in the log file?
Photo of Carien Moossdorff

Carien Moossdorff

  • 1 Post
  • 0 Likes
I think i got the same problem, log does say StopTrackingItems, dont know what this means though or what i can do about it (sorry im so dumb with these things :))
Photo of MurujM

Muruj

  • 2 Posts
  • 0 Likes
Hello JED,

actually I found now that this might really be the problem. At least it's not a problem with Miro - the torrents don't work in other clients as well. Plus there's a lot of timeouts in the log files when it comes to the tracker. I was just wondering why no one else seemed to have the same problem.

Thank you very much for your help!
Photo of William MeadeWM

William Meade

  • 1 Post
  • 0 Likes
Photo of JeffJ

Jeff

  • 1 Post
  • 0 Likes
im using windows XP and i have the same problem. My downloader log file says this.

timeout (Download status update) cumulative is too slow (5.002 secs)
Photo of martymandaM

martymanda

  • 1 Post
  • 0 Likes
Had the same problem, but I set up port forwarding in my router, restarted the router and then the downloads started.
Photo of brendaB

brenda

  • 1 Post
  • 0 Likes
i do not understand where i need to go to set up port forwarding pls help
Photo of bkfraileyB

bkfrailey

  • 1 Post
  • 0 Likes
I'm having the same problem, and I don't understand what you're saying about the tracker and port forwarder -- can anyone flesh out details for me? Thanks!
Photo of JED

JED, Official Rep

  • 870 Posts
  • 97 Likes
http://bugzilla.pculture.org/show_bug... - is fixed and we will be releasing 3.0.3 soon. The was a change in the youtube api.
Photo of sam

sam

  • 1 Post
  • 0 Likes
I've got the same issue using 3.0.3 on Fedora 13. The issue persists even with a completely disabled firewall, and I can download the video files using other means. (Attempting to download videos from both an audio podcast feed, and a Revision3 show feed).
Photo of Lori Robb

Lori Robb

  • 3 Posts
  • 0 Likes
I am also getting the same issue. I'm running Windows 7 and am not tech saavy. Don't know what to do. Used it on my old computer running Vista. Help!!!
Photo of Lori Robb

Lori Robb

  • 3 Posts
  • 0 Likes
I should add that my problems are when I try to run a torrent from pirate bay.
Photo of jj hydeJH

jj hyde

  • 1 Post
  • 0 Likes
same here, need the same info, tried running on my win 7, haven't tried the vista system yet
Photo of Lori Robb

Lori Robb

  • 3 Posts
  • 0 Likes
I finally got miro to go, jj hyde. Try downloading the torrent in internet explorer. It will automatically go to miro. After a few tries doing this it finally started downloading in miro. I'm running windows 7.
Photo of Ray McGill

Ray McGill

  • 1 Post
  • 0 Likes
Same here. Worked for months. I changed download locations and deleted some content. Now all dl say "Starting up". uninstalled and reinstalled. Still have config, so I bet it is corrupt.
Photo of craig.wicksonC

craig.wickson

  • 2 Posts
  • 0 Likes
I have exactly the same problem, downloading torrents from pirate bay and all stuck on starting up for ages now, not minutes - days!!
No one seems to have offered any solution...............
Photo of whomeW

whome

  • 3 Posts
  • 0 Likes
Same problem but with http downloads. They are usually stuck and "retrying in x seconds/minutes/hours". They may or may not then start at some later point, but as Miro only tries a few times with increasing intervals, it is really hard for it to happen. Downloads work fine with browser, so it is not a firewall or network issue. Please redesign the downloader and the retry system!
Photo of Liz Stroud

Liz Stroud

  • 2 Posts
  • 0 Likes
Same problem as of today. Just downloaded Miro, tried to download a game from piratebay, and everything is stuck on the "starting up" phase.
Photo of Liz Stroud

Liz Stroud

  • 2 Posts
  • 0 Likes
I'm on a Macbook OSX 10.5.8
Photo of Chris Brennan

Chris Brennan

  • 2 Posts
  • 0 Likes
I just upgraded to the newest version of Miro and now I cant download anything it says the are starting up but they just freeze at that point. Any suggestions?
Photo of denzil12D

denzil12

  • 1 Post
  • 0 Likes
If any one has some useful advice out their it would be great,i installed miro 4 and im stuck on start up,i then uninstalled and tried u torrent,,and it's stuck at 0% with no info in the file page.i have a mac 10.6.8 and have been downloading for a cuopel years.to my knowledge, which is limited the only thing i changed was miro 4.So if any one can help it would be helpful,as i'm about to give my mac a good kicking.
Photo of skellener

skellener

  • 2 Posts
  • 0 Likes
Same issue. Not even from torrents but straight downloads. Example: The new Game On show over on TWiT just hangs in Miro. I copy and paste the url into any browser an viola!

http://dts.podtrac.com/redirect.mp4/t...

It just works.

So why does Miro 4 hang so much?

Miro Version 4.0.6 (2c99d6e0)
Mac OS X 10.6.8
Photo of googlegirlG

googlegirl

  • 8 Posts
  • 0 Likes
i faced the same problem while downloading videos from youtube