Unable to install miro 4.0.6 on windows 7 x64

  • 1
  • Problem
  • Updated 5 years ago
I'm having trouble getting Miro to install. Nod32 was initially quarantining the file because of OpenInstall. I've disabled all of Nod32's monitoring and am able to download and run the install file, but when it gets to the end of its installation process, the window just disappears and nothing has been installed.

Here are the steps I follow:
1. Download Miro_Setup.exe for Windows
2. Run Miro_Setup.exe
3. Click Next
4. Click "No Thanks" twice
5. Click Next two more times

At this point, the Installer shows that Miro is "Downloading..." and the installer has an icon in my task bar. Once the downloading bar is very near to being complete, the window just vanishes. Mousing over the icon in my taskbar causes it to disappear as well, suggesting that the installer has crashed.

Repeating these steps produces the same behavior.

I use Nod32 antivirus, and have disabled Real-time file system protection, Document protection, and Web access protection. I also have disabled Windows Firewall.

Any tips would be appreciated.
Photo of pritchard.alex


  • 1 Post
  • 0 Reply Likes
  • Annoyed

Posted 5 years ago

  • 1
Photo of Harris


  • 2 Posts
  • 0 Reply Likes
I have had the same problem have posted a few times for help but have not got any responces. If I delete miro and download it again will I loose all my stuff ?.
Photo of stephen.b.gallant


  • 1 Post
  • 0 Reply Likes
I've been having the same problem. It seems the downloader isn't working properly.

The install file is mirrored here:

Scroll down until you find Miro-4.0.6.exe.

That should solve the problem. :)
Photo of Falkon


  • 1 Post
  • 0 Reply Likes
Same here..wrote emails but no answers yet.
Wonder if it is all just a joke...Converter seems to be ok though.

that link does not work either Stephen.b.gallant..

C:\...\...\Documents\Softwares\Players\Miro-4.0.6.exe could not be saved, because the source file could not be read.

Try again later, or contact the server administrator.
Photo of JED

JED, Official Rep

  • 870 Posts
  • 98 Reply Likes
Hi thanks for the detailed problem report - we are working on getting this resolved. In the meantime the osuosl link is a good alternative.
Photo of JED

JED, Official Rep

  • 870 Posts
  • 98 Reply Likes
I can confirm that this is fixed, and you'll need to download a new installer from http://www.getmiro.com/download.

thanks for the patience.
Photo of Aurelius Marcus

Aurelius Marcus

  • 1 Post
  • 0 Reply Likes
The miro_setup.exe process has some issues concerning third party cookies and the unexpected installation of an AVG security toolbar.

I set my PC to prompt me each time a third party website wishes to save a cookie, and while miro_setup was running this dialog appeared for cookies from market.cloins.com:

After repeatedly clicking block cookie the miro_setup process continued.

As an aside, OpenInstall, Inc. registered the domain cloins.com on 1 February 2012 and the domain openinstall.com on 5 September 2001. As far as I can tell cookies from cloins.com are not needed to install or run Miro - at least when I block both domains Miro downloaded and played videos normally.

I looked inside the full installer from http://ftp.osuosl.org/pub/pculture.or... and found the toolbar-silent.exe within \$PLUGINSDIR\.

A Virus Total scan shows DrWeb, NOD32 and VIPRE all identifying toolbar-silent.exe as Zugo adware. See https://www.virustotal.com/file/b8add...

The 2011 April version of Miro installer instead had the smaller zugo-silent.exe inside \$[36]\$PLUGINSDIR\ , and the Virus Total report is here: https://www.virustotal.com/file/71b31...

Could that explain the problems some people are reporting? Is there a version of the full installer without the toolbar plugin I could test?

While the miro_setup process was running (see the "Initializing" window above) Task Manager listed application CloudInstaller and process Miros_setup.exe (which consumes about 1 % of CPU and 14 megabytes RAM).

After I had blocked all the cookies attempts a window titled "Miro Downloader - Powered by AVG CloudInstaller" appeared as follows:

I read the Privacy policy and End-User License Agreement but could not find any explicit statement that a toolbar would be installed. The privacy policy mentions toolbar once only:


Like most websites and toolbar products, OpenInstall may use cookies and web log files to track your usage of the Website and the Services."

Is that implying Cloudinstaller is a toolbar?

After I clicked Next I unchecked all the install options in the Miro Downloader:

Note that I unchecked all the choices under Custom, but that there appears to be no choice to *not* install the AVG Toolbar!

Is this deliberate or an oversight?

I then clicked Next and the dialog displayed "Where should the program be installed?"

Notice that I changed the installation folder to one of my choosing (the installer ignored my specified location and used "c:/Program Files/Participatory Culture Foundation/Miro" regardless).

I clicked next and the window changed to "installing" and I was surprised to see it was "Downloading" the AVG Toolbar first:

After the Installing window had completed the download of AVG Toolbar it started to install it at the same time as downloading Miro:

After the Installing window had finished downloading Miro it launched Miro and I clicked Help / About to display the version :

This new Miro did run and download new videos normally, but I discovered these problems:
1. Miro was in c:/Program Files/Participatory Culture Foundation/Miro and not where I had specified C:/r/progs/Miro.
2. Add and Remove Programs showed an AVG Toolbar was installed - which I promptly uninstalled, and then I uninstalled Miro

I also checked my registry for any traces of Zugo adware (present in 2011 versions of the Miro setup): I found no entries for Zugo , "searchtoolbar", "search toolbar" nor "startnow".

After I uninstalled the undesired AVG Toolbar using Add and Remove Programs I searched avg.com for "How to uninstall AVG Toolbar" and found this procedure:


AVG tells you to first download an AVG installation file, to run it and to choose the "Repair installation option." This did not work for me because Windows reported it conflicted with Microsoft Essentials which I use instead of AVG (I do not use AVG).

In short, I suggest Miro attends to these issues, as forcing a toolbar on users that could be difficult to uninstall is not very friendly. As for me, even though I believe I have eradicated the toolbar I will likely perform a System restore to before I tried this Miro update.

My system specs:
CPU AMD Athlon 64X2 Dual 5000+ (2614)
GPU nVidia GeForce 6500
RAM 3 GB DDR2 DIMMS: 2 of PC2-5300 (667 MHz) + 1 of PC-6400 800 MHz
OS Windows Vista Home Premium 32 bit
Photo of Chris Brennan

Chris Brennan

  • 2 Posts
  • 0 Reply Likes
I have been using Miro for over a year and I just upgraded yesterday to the new version now when I try to download it gets stuck in the startup mode not sure what to do. I run windows 7. Please help.
Photo of Romarin


  • 1 Post
  • 0 Reply Likes
Finally tried the last version. I did not try the installer and tried the full file "Miro-4.0.6.exe". I was using the 4.03 version.

installed with no problem.

Can finally choose french language without too much issues because I was getting some other language last couple version... even though there are some menus or options still in other language.

I like the program even though it has some stability issues. I will probably look for an alternative if things does not improve.

The language is secondary to stability.

I am careful and not updating often.

I am not looking for more features.

Windows 7 SP1 x64