WEBM results in very poor quality

  • Problem
  • Updated 1 year ago
I'm trying to encode a video into webm and results in very poor quality. Source is a 1028x720 .mov video of high quality. Miro video converter does a great job producing the Theora ogv file, but the webm file results in very reduced quality and visual artifacts... any ideas if it's possible to fix the encoding?

Thank you!
Photo of felipe

felipe

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 16
Photo of JED

JED, Official Rep

  • 870 Posts
  • 97 Reply Likes
There is an updated version of the webM library that we will have in a future version and should improve this issue.
Photo of sorin.niculae89

sorin.niculae89

  • 1 Post
  • 0 Reply Likes
I have this problem as well, I get bad webm quality only on Mac OS.
Any ETA on this new version?
Photo of thisismarkus

thisismarkus

  • 1 Post
  • 0 Reply Likes
Same issue here. Is there now a fix for this? Or are there any kind of different settings or such I can use?
Photo of Jay Murphy

Jay Murphy

  • 1 Post
  • 0 Reply Likes
Hello - I am wondering about the status of this too. MP4 and OGV formats are coming out nice and clear when we start with an WMV format.

Just wondering if this is going to be updated or if there are option we can set to improve the WEBM output file.

Thanks!
Photo of Sverker Hahn

Sverker Hahn

  • 1 Post
  • 0 Reply Likes
I also get poor quality, it is really crap!

I will be happy for some improvement.
Photo of emgee

emgee

  • 6 Posts
  • 1 Reply Like
Any word on an update?
Photo of Kevin Airgid

Kevin Airgid

  • 4 Posts
  • 1 Reply Like
6 months ago and no reply, you may try this (although it's not cheap) http://www.sorensonmedia.com/video-en...
Photo of lerone

lerone

  • 1 Post
  • 0 Reply Likes
same here :-(
Photo of marsofearth

marsofearth

  • 1 Post
  • 1 Reply Like
WEBM is simply not an option that should be allowed right now... Very Poor quality,

look forward to an update to resolve.

Any suggestions for a good H.264 to WEBM converter?
Photo of Kevin Airgid

Kevin Airgid

  • 4 Posts
  • 1 Reply Like
same here, would be nice to find a setting to fix this... or at least an "advanced" user mode?
Photo of emgee

emgee

  • 6 Posts
  • 1 Reply Like
If you want to convert a single video, the encoder that Miro uses will do a decent job of converting to WEBM, it's just that the preset is terrible. To manually convert, you can use the following command from a Terminal window:

"/Applications/Miro Video Converter.app/Contents/Resources/ffmpeg" -i "/path/to/video.mp4" -f webm -vcodec libvpx -acodec libvorbis -ab 160000 -b 2000k -pass 2 "/path/to/video.webm"

You can mess with the number after the -b to increase or decrease quality.
Photo of spidersilk

spidersilk

  • 1 Post
  • 0 Reply Likes
emgee - thank you for this! Very helpful. But could you give us some indication of what sort of range of numbers after the -b might mean what in terms of quality? i.e. is the 2000k you put there a considerably higher quality than the preset? What sort of value might one want to put there in order to have a similar quality in MIro's WebM conversions as in the MP4 conversions?

With the video I'm currently working with, the MP4 conversion came out great, but the WebM version was really awful.

Thanks!
Photo of emgee

emgee

  • 6 Posts
  • 1 Reply Like
The -b is bitrate for the video portion of the file. I've done a bit more futzing around on this and for streaming video, I typically use -b 1125k and leave off the -pass 2. 1125k is the same bitrate as the 480p trailers on Apple's trailer's site (but they're using a better compression software and the h264 codec which looks a smidge better per same bitrate).

You can also check out http://www.adobe.com/devnet/flash/app... which gives a rough guide. But again, this calculator is for h264, not WebM, so you'll have to play with the numbers to find what's right for you.
Photo of emgee

emgee

  • 6 Posts
  • 1 Reply Like
Ok, current command I use:

/Applications/Miro\ Video\ Converter.app/Contents/Resources/ffmpeg -i /path/to/input/video.mp4 -f webm -vcodec libvpx -acodec libvorbis -ab 160000 -b 1152k /path/to/output/video.webm
Photo of Kevin Airgid

Kevin Airgid

  • 4 Posts
  • 1 Reply Like
thank you!
Photo of Kevin Airgid

Kevin Airgid

  • 4 Posts
  • 1 Reply Like
o, how do we do this on Windoz?
Photo of emgee

emgee

  • 6 Posts
  • 1 Reply Like
Search for a file called 'ffmpeg.exe' — I imagine it would be in C:\Program Files\Miro Video Converter or C:\Programs\Miro Video Converter and run the same command as above with that executable. I don't have a Windows Computer to test the exact paths with. You'd also need to change all the /'s to \'s.

If you can't find the ffmpeg.exe on your computer, you can download it from Github: https://github.com/pculture/mirovideo...
Photo of rick

rick

  • 1 Post
  • 0 Reply Likes
After a bit of noodling I got it to work too. Thanks Emgee!
Photo of Rich Pasco

Rich Pasco

  • 2 Posts
  • 0 Reply Likes
I have to add my "ditto" to those who were disappointed in the WebM video quality. I just downloaded Miro Video Converter Ver. 2.5 and converted an FLV file (1280 x 720, 1 min 43 secs, 30 fps, 2757 kbps, 36,938,465 bytes total), The resulting WebM was just 5,353,100 bytes (14% of the original) but terrible visual quality (very "blocky" and blurry, lots of artifacts not present in the original). I was hoping that Miro Video Converter would either offer a "Settings" dialog, or default to keeping the original video quality, or both, but it seems to do neither. Next, I'll play around with emgee's suggestion for manually setting parameters on the ffmpeg command line.
Photo of Rich Pasco

Rich Pasco

  • 2 Posts
  • 0 Reply Likes
I tried the parameters emgee suggested and got the error message

Cannot read file 'ffmpeg2pass-0.log': No such file or directory

So I created an empty file named ffmpeg2pass-0.log which fixed that.

Next error was:

Please use -b:a or -b:v, -b is ambiguous

So I changed "-b 2000k" to be "-b:v 2000k" which fixed that.

Next error was:

[libvpx @ 03E54020] Failed to initialize encoder: Invalid parameter
[libvpx @ 03E54020] Additional information: rc_twopass_stats_in requires at least two packets.

Error while opening encoder for output stream #0.0 - maybe incorrect parameters such as bit_rate, rate, width or height

Here, I will assume that last line was a consequence of the first two. But I need help understanding how to fix these.
Photo of emgee

emgee

  • 6 Posts
  • 1 Reply Like
Yeah, I keep on messing up the command. Here's what I use now.

/Applications/Miro\ Video\ Converter.app/Contents/Resources/ffmpeg -i /path/to/input/video.mp4 -f webm -vcodec libvpx -acodec libvorbis -ab 160000 -b 1152k /path/to/output/video.webm
Photo of JED

JED, Official Rep

  • 870 Posts
  • 97 Reply Likes
this will be fixed by MVC3 - our next release which is coming soon.
Photo of bboaby

bboaby

  • 1 Post
  • 0 Reply Likes
I never used MiroConverter, so i had no idea about what happened. But i know a useful way to convert videos to WebM or WebM to other videos with high quality.