Help get this topic noticed by sharing it on Twitter, Facebook, or email.

ImageExchange 2.2 will not install in Mac Firefox 3.6.13

I tried today to install the plugin for Firefox on my Mac. Firefox says ImageExchange is not compatible.

Versions:
- ImageExchange 2.2 mac
- Firefox 3.6.13 on Mac (10.6) (everything latest as of 2011/02/25)
1 person has
this problem
+1
Reply