FTP pipe not working

  • Question
  • Updated 5 years ago
  • Answered
I can't get the ftp service to work. What should I be entering in the fields? I have entered the username and password as requested, and for server path I enter ftp.server.com/home/user as the path from root, but have also tried without a path. Nothing works.
Photo of GregG

Greg

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 13
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
My first guess would be that you may have specified the path incorrectly. "Server Path" should look like ftp.server.com:/your_directory/. Keep in mind that the path is based on the FTP root directory and not the system. If you happen to be logged in to your FTP server from the command line you can cd to your desired directory and type "pwd" to determine the path.
Photo of Hel M.

Hel M.

  • 7 Posts
  • 0 Reply Likes
I tried this, and it didn't work for me. I have fireftp set up, and it works fine. in fireftp, I enter the host as helenmcgee.net, my domain. I tried just that in pixelpipe, didn't work. tried ftp.helenmcgee.net, no luck, tried ftp://helenmcgee.net, also no luck. if I want to log into helenmcgee.net/pics/cell, what would I type?
Photo of

  • 3 Posts
  • 0 Reply Likes
Same error.

server paths that I've tried (I have tried the following permutations on multiple FTP accounts on multiple servers)

ftp.refriedfilms.com/
ftp.refriedfilms.com
ftp.refriedfilms.com/../
ftp.refriedfilms.com/images/
ftp.refriedfilms.com/images
ftp.refriedfilms.com:/images
ftp.refriedfilms.com:/../

refriedfilms.com
refriedfilms.com/
refriedfilms.com:
refriedfilms.com:/

ftp://ftp.refriedfilms.com/
ftp://ftp.refriedfilms.com
ftp://ftp.refriedfilms.com/../
ftp://ftp.refriedfilms.com/images/
ftp://ftp.refriedfilms.com/images
ftp://ftp.refriedfilms.com:/images
ftp://ftp.refriedfilms.com:/../

68.178.254.110
68.178.254.110/
ftp://68.178.254.110
ftp://68.178.254.110/
ftp://68.178.254.110/images
ftp://68.178.254.110:/
ftp.68.178.254.110:/
68.178.254.110:/

*68.178.254.110=server IP
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
You may be specifying your path incorrectly, you can determine it by logging in to your server from the command line and typing 'pwd'. In the end you should end up with refriedfilms.com:/path.

If you'd like to create a test account for us we can log-in and verify setup, just send us the log-in details to contact@pixelpipe.com and we'll check it out.
Photo of

  • 3 Posts
  • 0 Reply Likes
---------------------command line------------------
ftp> pwd
257 "/" is your current location
---------------------------------------------------------

I'll see if any of my accounts allow creating extra FTP users.

Thanks,
-Jason
Photo of

  • 2 Posts
  • 0 Reply Likes
Same here Ipercon, I even tried including portnumbers but still no go.
I'm trying for some weeks now...
I use ftp a lot on different platforms and envirenments but never had this problem.
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
We've made a few changes to the way we handle FTP that should resolve your issue. Can you give it another shot?
Photo of

  • 2 Posts
  • 0 Reply Likes
Hi Brett

This did solve my problem. It works just great now.
I had to put address like this:
ftp.server.com:/first_directory/second_directory

Thanks!
Photo of

  • 2 Posts
  • 0 Reply Likes
one try... entered the same data.... and it worked this time!
Thanks!!!
Photo of

  • 3 Posts
  • 0 Reply Likes
bingo!
Photo of pattulus

pattulus

  • 1 Post
  • 0 Reply Likes
cool... now I have to remember it - what about giving an example on the website. This would spare many users the way to look out for the solution. I’m glad I found this answer here because otherwise I’d suggested that my FTP isn’t compatible with your service. You know how FTP’s are...
Photo of

  • 44 Posts
  • 6 Reply Likes
FTP is ancient.^M
I've added some helpful text to the settings page.^M
It will go out in the next push.^M
Photo of

  • 4 Posts
  • 0 Reply Likes
"ftp.server.com:/first_directory/second_directory" is confusing to me. It's not any standard notation (where did the colon come from?) and it doesn't explain what it's supposed to mean.

If I want my pics to land at ~username/public_html on ftp.server.com, what do I put in the box? An ftp login lands me at ~username. Do I go with "ftp.server.com:/~username/public_html", "ftp.server.com:/public_html", or "ftp.server.com:/username/public_html"? Answer is none of the above, because none of them work.

You should have the server name and desired directory in separate text boxes (like every FTP program I've ever used!) to cut the confusion:

server: ftp.server.com
directory: public_html
Photo of

  • 4 Posts
  • 0 Reply Likes
Oh yeah, an error message saying the upload to the FTP server failed might be cool, too.
Photo of

  • 4 Posts
  • 0 Reply Likes
OK, at least 1 time I hit the settings correctly. The reason I couldn't see the file over http was that the permission were not set to allow it. Can an option be added to allow the file to have the proper permission?
Photo of TJT

TJ

  • 1 Post
  • 0 Reply Likes
I'm having pretty much the same issue. I had an ftp pipe that was working, than stopped working a few weeks ago. I tried editing the pipe, and tried adding a new pipe, but I still can't get it working. this is what I enter in the fields:
Username=myusername
Password=mypassword
Server Path=ftp.myservername.com:
/=cellpics
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
We've just released a number of updates to our FTP service. Go ahead and try again, get back to us if you're still experiencing issues.
Photo of SwissalpS

SwissalpS

  • 2 Posts
  • 0 Reply Likes
I've been trying all kinds of combinations and it won't connect.
using any FTP client I have, I successfuly connect with following scheme:
username = username@mydomain.tld
server = ftp.mydomain.tld
password = mypassword
path = /

I'm also confused why there are two fields labeled 'server path (host)'
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
It looks like our web developer made a mistake with the description strings when we was working on the layout for the page. The bottom filed should be the path and the one above it should be the server address.

You might want to create a directory for upload, we've seen permissions issues with some users trying to connect to the root of their FTP server in the past.
Photo of SwissalpS

SwissalpS

  • 2 Posts
  • 0 Reply Likes
thanks for clarifing the fields.

I made a subfolder for upload as you suggested.
To avoid permission issues, I set it's mode to 777
unfortunately, it's still not connecting.
Photo of Freakshow Firestarter

Freakshow Firestarter

  • 2 Posts
  • 0 Reply Likes
Hi,
I had no problem setting this up, but big problems after I did!
I have an ftp server that I only use for sending large images to other companies, like our printer. I don't have any web production on that server, thank god. I made a new ftp account and directory for pixel pipe to test out this service.

I posted a couple, and pixel pipe did a great job as usual updating my social networks and even sent the file to the ftp server. YAY!!! At this point I was thinking I would actually put in my product server's ftp user/pass and give pixelpipe access to my website ftp. DON'T DO THIS!!!

A couple days later I went to look at the pictures on the server and my pc's virus software stopped me, finding a JS/Obfuscated virus on the page. All of my files had been edited, with the first line of the file having a php eval line called, with a huge nasty string as the argument. So my server got all screwed up, I lost the images that were up there, and I possibly infected some printing companies if they were still using the server to get my files. I had a backup folder, so I reloaded the original stuff, and got it working. A couple days later, same problem. I again reloaded the original stuff because I needed the printers to pick up the files, but this time I deleted the ftp account. And now my server is fine, for a couple of weeks.

In conclusion, giving out the ftp login info to pixel pipe resulted in me getting hacked on that server, a problem that persisted until I deleted that ftp account. I doubt that pixel pipe did this maliciously, but they have a security problem that ended up compromising my data.

If you do plan to use pixelpipe ftp, do it in a safe place that won't affect your site and use a new ftp account that you can delete when things start getting screwed up.

I really love pixelpipe, great service! Hopefully they hear about this and fix the issue, but until they do I won't be using the ftp feature, and am becoming worried about my other logins.