my own hosted wordpress blog - API endpoint URL problem

  • 3
  • Question
  • Updated 6 years ago
  • Answered
I have my own hosted wordpress blog @ mysite.com/theblog/ ( xmlrpc.php file is in that directory)
When I add my custom blog using mysite.com/theblog/ xmlrpc.php , username & password I et this message:
Sorry, we couldn't find an API endpoint URL for this service, if you know it, you may enter it directly.
any ideas?
Photo of andreshm

andreshm

  • 3 Posts
  • 0 Reply Likes
  • trying to figure this out..

Posted 7 years ago

  • 3
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
Did you figure out your API endpoint? If you send us a link to your blog we might be able to help you out.
Photo of andreshm

andreshm

  • 3 Posts
  • 0 Reply Likes
Nope. I just was waiting for some help.
URL: http://bypia.com/theblog/

endpoint http://bypia.com/theblog/xmlrpc.php
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Reply Likes
That looks like the right endpoint. You are using Metaweblog and not the Wordpress.com Pipe, right? http://pixelpipe.com/destination/add/...
Photo of andreshm

andreshm

  • 3 Posts
  • 0 Reply Likes
When I use the Wordpress link, I add my user/ password and URL fro my blog, but I always get : Unable to add Pipe. Wordpress.com says: Bad login/pass combination ( I double checked). So I was under the impression that this is only for wordpress hosted blogs, That's when I tried the "Add a blog by address" that didn't worked either.
I'm using WordPress 2.9.2.
thanks!
Photo of messiahmews

messiahmews

  • 1 Post
  • 0 Reply Likes
I'm having the same problem with my own hosted wordpress blog. I have one on Wordpress.com, but I want to add my own hosted blog on Flickr.com

It keeps telling me "The username and password you entered were not valid."

They most certainly are valid. I'm logged on them now. I don't get it.

Maybe it thinks I should add my wordpress hosted blog, but it's for my music stuff, and is not related to the content on Flickr.com
Photo of Terri Ream

Terri Ream

  • 1 Post
  • 2 Reply Likes
I had the same issue. This worked for me...
***Note: If you use a Wordpress self-hosted blog, in your Wordpress dashboard under Settings > Writing > Remote Publishing be sure to check both Atom Publishing Protocol and XML-RPC. Then, in your settings on Flickr for that blog, enter your Wordpress API Endpoint; for example: yourdomainame.com/xmlrpc.php

http://www.flickr.com/help/blogging/
Photo of weitergehen

weitergehen

  • 1 Post
  • 0 Reply Likes
I get the same error message with the following blog:

http://design.speak-friend.com
Photo of Jonathan

Jonathan

  • 1 Post
  • 0 Reply Likes
Same problem - trawled thru' google for fixes and tried them all except the .htaccess changes - don't think I should have to mess that much with standard self hosted install.

Any more ideas anybody????

Pixelpipe.com ????

Endpoint of site is at http://hiexposure.com/xmlrpc.php

Thanks!
Photo of Venessa Nolan

Venessa Nolan

  • 1 Post
  • 0 Reply Likes


Pixelpipe is still posting my videos to my Wordpress blog after I removed the pipe as a posting destination. I remember installing something on my wordpress blog an API key or something but can't find this now to remove....

i would really really really appreciate anyones help with this, as I don't want my videos posted on my blog.