Unable to add wordpress pipe : invalid XML response

  • Problem
  • Updated 5 years ago
  • In Progress
Hello, I am trying to add a new wordpress pipe and here should be the URL :

http://gglobal.org/gg/blog/xmlrpc.php

and this is the answer I get :

Unable to add pipe. Wordpress.com says: Target URI: http://www.wordpress.com/xmlrpc.php returned invalid XML response.

N.B. : The xmlrpc function on wordpress admin settings is enabled and the file is in the good place...

Could not find any similar problem in that forum , I put the same question in the question topic, I guess that is why I did not get any answer from you guys...

please help !
Photo of Petri71

Petri71

  • 14 Posts
  • 0 Likes
  • confused

Posted 6 years ago

  • 2
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Likes
It looks as though you're entering in the wrong endpoint or user name and password. Please verify your endpoint and try again at http://pixelpipe.com/destination/add/...
Photo of Petri71

Petri71

  • 14 Posts
  • 0 Likes
Thank you for this quick answer,

I alreday tried many ways

I am sure of the login and PW, that is the one I am using to log into the blog.

As for the URL, I checked via ftp and the xmlrpc.php is there :

http://gglobal.org/gg/blog/xmlrpc.php

I also tried :

http://www.gglobal.org/gg/blog/xmlrpc...

and

www.gglobal.org/gg/blog/xmlrpc.php

but nothing works, I always get the wrong answer.

Do you think the php file could be corrupted ? I unchecked and checked the xmlrpc function in the blog but it does not change anything...
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Likes
Can you create a temporary account on the server and send us the log-in to contact@pixelpipe.com? We won't post anything however will be able to view the error the server is returning to determine the issue.

What version of Wordpress are you using?
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Likes
We found the issue and will be deploying a fix later today. We'll get back to you when the fix is live.
Photo of duoduo

duoduo

  • 2 Posts
  • 0 Likes
could you tell me the issue's detail?
Photo of duoduo

duoduo

  • 2 Posts
  • 0 Likes
I met the same problem as you!
and I debug the progrom , it seems the response file can not be find.

To Brett Butterfield:
pls fb to me too!~
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Likes
We've discovered the issue you're experiencing and have a fix for the problem in QA for testing now. We're planning on a release next week and will notify you as soon as the solution is available.
Photo of Petri71

Petri71

  • 14 Posts
  • 0 Likes
Hello,

any news for this problem ?
Photo of dualtstudent05D

dualtstudent05

  • 10 Posts
  • 0 Likes
Have someone a response ?
Photo of Petri71

Petri71

  • 14 Posts
  • 0 Likes
I think they're still fixing .... I found another solution anyway...
Photo of Brett Butterfield

Brett Butterfield, El Capitan

  • 1561 Posts
  • 124 Likes
You're probably trying to add the wrong Pipe, make sure you pick the right one based on if you are hosting Wordpress on your server or using wordpress.com

http://wordpress.com hosted blog: http://pixelpipe.com/destination/add/...

Self hosted (your server) Wordpress blog: http://pixelpipe.com/destination/add/...
Photo of dualtstudent05D

dualtstudent05

  • 10 Posts
  • 0 Likes
I found the problem : the problem is the plugin "related tag" ! Be carefull with this plugin :-( If you desactivate it, it works fine !