Help get this topic noticed by sharing it on Twitter, Facebook, or email.
I’m frustrated

Polar RS800CX IRDA connection problem

I have a RS800CX Multi G3 but cannot get the connection to work between Polar ProTrainer and the watch. I've tried to re-install the ProTrainer and the IRDA software. It does not work. The USB IRDA blink red - but the watch does not respond
9 people have
this problem
+1
Reply
  • Hi Skawbo,

    Sorry to hear you are having a problem. Take a look at this document. http://tinyurl.com/rbztjx

    If that does not resolve your issue please let me know

    Thanks

    Chris @ Polar
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • Hi Chris,

    thank you for a fast repply - before posting my problem, I've allready seen this infomation on the very good Polar site.

    BUT this dont solve my problem.

    ProTrainer works fine. After installing the IRDA software, and connecting the black USB IRDA devise I can see that driver is installed, and when trying to connect the watch, the USP blinks - but the watch does not respond. The watch works fine, but it seems as if the watch and the IRDA USB does not communicate or links up.

    Somewhere on the web, I also notice that a "IRDA Bridge" should also be visible when checking "my computer, properties, hardware, device manager, IR device - here I only see the MosChip, MosIrUsb". I do not get the small icon on the lower right hand corner showing IRDA connection.

    Shall this only be visible when the watch and IRDA device is in contact or sould this also be visible before you press the watch to connect.

    I've contacted Polar Denmark, who suggested trying to connect my watch to a running friend's computer to diagnostic if the problem is related to my brand new watch or the USB pin or software. I hope to have tried this by the end of this week.

    I've also tried installing the ProTrainer and the IRDA software on an another PC - again without any success.

    I'm getting very frustrated - not being able to view my training on my PC.

    pls help

    Skawbo
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • I had this exact problem with my RS800CX that I just recently purchased. I previously had a RS800. I noticed that the RS800CX came with a black cable and different software. (drivers) So I uninstalled my old software (drivers) and installed the new driver software that came with the watch. Everything seemed fine for about two weeks. Then it just stopped working. I tried contacting Polar customer support. (which is horrible in my opinion) They were no help at all. I was thinking the problem was with my watch, But just for fun, I tried my watch at Lifetime Fitness where I workout. They use Polar there. My watch worked perfectly there. So, I went out and bought the old white cable with the older software drivers. Uninstalled the new software drivers. Installed the older software drivers. Plugged in the white cable to complete the installation. Now it's working perfectly again. I think there is a problem with the black cable/IR receiver.
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated

  • I am having the exact same problem. Watch seems to work, software seems to be working, IRDA seems to be working... YET no connection. I have the RS800 (NOT THE CX)
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. kidding, amused, unsure, silly happy, confident, thankful, excited indifferent, undecided, unconcerned sad, anxious, confused, frustrated